Bug 738863 - [6.3 FEAT] Two Stage Dumper framework - userspace part
[6.3 FEAT] Two Stage Dumper framework - userspace part
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: s390utils (Show other bugs)
6.3
s390x All
high Severity high
: beta
: 6.3
Assigned To: Dan Horák
qe-baseos-daemons
: FutureFeature, OtherQA
Depends On:
Blocks: 704634 705085 767187
  Show dependency treegraph
 
Reported: 2011-09-15 20:22 EDT by IBM Bug Proxy
Modified: 2013-01-03 03:40 EST (History)
5 users (show)

See Also:
Fixed In Version: s390utils-1.8.2-43.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:11:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
s390-tools-rhel6-kdump-two-stage.patch (61.00 KB, text/plain)
2011-12-09 08:30 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 74348 None None None Never

  None (edit)
Description IBM Bug Proxy 2011-09-15 20:22:25 EDT
1. Feature Overview:
Feature Id: [74348]
a. Name of Feature: [6.3 FEAT] Two Stage Dumper framework - userspace part
b. Feature Description

With this feature the Linux kdump framework is ported to Linux on System z and is integrated in the already available System z stand-alone dump tools and shutdown actions framework.
This leads to the following enhancements for System z kernel dumps:
??? Dump time and size can be reduced using page filtering with the makedumpfile tool.
??? Dump disk space sharing is possible for server farms using network dump.
??? Dump setup is made easier using existing kdump setup GUIs of Linux distributions.

The integration with the Linux on System z stand-alone dump tools ensures that the dump reliability with kdump will be almost as high as with the current solution.

The kdump support on s390 has the following advantages compared to other architectures:
???  On z/VM diagnose 10 is used to release the reserved crashkernel memory. Real/backed memory is required only for the kdump image and ramdisk. So almost no real memory will be wasted.
???  On System z crashkernel memory is removed from the kernel page tables. Therefore no memory for page tables is wasted.
???  Using the System z stand-alone dump tools, it is still possible to dump early crashes, when kdump is not yet initialized.


2. Feature Details:
Sponsor: LTC zSeries BOE
Architectures:  zSeries - 64 native, 

Arch Specificity: purely arch specific code
Affects Kernel Modules: No
Delivery Mechanism: Backport
Category: other
Request Type: Package - Feature from IBM
d. Upstream Acceptance: In Progress
Sponsor Priority P1
f. Severity: high
IBM Confidential: No
Code Contribution: IBM code
g. Component Version Target: ---

3. Business Case
This RAS feature requests the framework to introduce future dump extensions that are required to improve serviceability and enable serviceability for customers that run huge images.  




4. Primary contact at Red Hat:
John Jarvis, jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com

Technical contact(s):
Hans-Georg Markgraf, mgrf@de.ibm.com
Comment 2 IBM Bug Proxy 2011-10-05 11:31:55 EDT
------- Comment From mgrf@de.ibm.com 2011-10-05 11:30 EDT-------
This feature is part of the following set of related requests that address all components impacted by this functionality

74347 - 738862 [6.3 FEAT] Two Stage Dumper framework - kernel part
74348 - 738863 [6.3 FEAT] Two Stage Dumper framework - userspace part
74349 - 738864 [6.3 FEAT] Two Stage Dumper framework - makedumpfile part
74350 - 738865 [6.3 FEAT] Two Stage Dumper framework - crash part
74352 - 738866 [6.3 FEAT] Two Stage Dumper framework - kexec-tools part
74353 - 738867 [6.3 FEAT] Two Stage Dumper framework - installer
Comment 3 John Jarvis 2011-12-07 14:24:49 EST
IBM is signed up to test and provide feedback, setting OtherQA.
Comment 4 IBM Bug Proxy 2011-12-09 08:30:56 EST
Created attachment 544542 [details]
s390-tools-rhel6-kdump-two-stage.patch


------- Comment on attachment From brueckner@linux.vnet.ibm.com 2011-12-09 08:26 EDT-------


Summary:     kdump: Add s390-tools kdump support
Description: The following features have been added for s390-tools kdump
             support:
             - kdump base support:
               The lsshut tool prints information when kdump is enabled.

             - PSW restart support:
               * dumpconf: The dumpconf service now configures the same action
                 for the restart trigger as for the panic trigger.
               * ipl_tools: The lsshut tool now shows the action for the
                 restart trigger.

             - zgetdump: vmcoreinfo support
               The zgetdump tool now prints UTS name information for dumps
               and creates a VMCOREINFO note section for ELF target dump
               format.

             - zgetdump: makedumpfile kdump format support
               The zgetdump tools can now print information on makedumpfile
               generated dumps (kdump format) with the --info option.

             - zgetdump: kdump failure recovery support
               If kdump failed and a stand-alone dump is created afterwards,
               with the new zgetdump --select option, the user can choose
               between the production system dump and the failed kdump dump.
Comment 5 Cong Wang 2011-12-21 04:24:04 EST
Hi, IBM,

This BZ is opened for kexec-tools, but it seems that patch you provided is not for kexec-tools. Can you explain it?
Comment 6 IBM Bug Proxy 2011-12-21 04:50:27 EST
------- Comment From michael.holzheu@de.ibm.com 2011-12-21 04:50 EDT-------
(In reply to comment #8)
> Hi, IBM,
>
> This BZ is opened for kexec-tools, but it seems that patch you provided is not
> for kexec-tools. Can you explain it?

The patch covers the s390-tools changes for the s390 kdump port.  There is anther bugzilla that provides the kexec-tools patches (TLC bug #74352, Redhat bug #738866).
Comment 7 Cong Wang 2011-12-21 06:05:16 EST
I knew, but the Component of this BZ is kexec-tools and is assigned to me. :-/ If this is for s390-tools, I think you need to move the Component to s390-tools?
Comment 8 IBM Bug Proxy 2011-12-21 09:00:44 EST
------- Comment From michael.holzheu@de.ibm.com 2011-12-21 08:52 EDT-------
(In reply to comment #10)
> I knew, but the Component of this BZ is kexec-tools and is assigned to me. :-/
> If this is for s390-tools, I think you need to move the Component to
> s390-tools?

I would assume so. The s390-tools maintainer at your side is Dan Horak.
Comment 11 John Jarvis 2012-01-10 12:18:54 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux
team for inclusion in a Red Hat Enterprise Linux minor release.   As a result
of this evaluation, Red Hat has tentatively approved inclusion of this feature
in the next Red Hat Enterprise Linux Update minor release.   While it is a goal
to include this enhancement in the next minor release of Red Hat Enterprise
Linux, the enhancement is not yet committed for inclusion in the next minor
release pending the next phase of actual code integration and successful Red
Hat and partner testing.
Comment 14 IBM Bug Proxy 2012-06-07 04:16:09 EDT
------- Comment From mgrf@de.ibm.com 2012-06-07 08:00 EDT-------
The userspace part of this feature is verified on R 6.3 snapshots
-> set to verified on IBM site

The feature remain technical preview for R 6.3 per Red Hat decision.
There are four known bugs to be resolved

80231 - RH801344 - Rebuilding kdump image - No such file or directory
- warning message that dump device is not available
- can be ignored, but is very confusing for customers
-> fix available but not included in R 6.3

81412 - RH820474 - kdump service not able to start .. on SCSI device
- kdump cannot be used on SCSI devices - limitation for R 6.3
- fix to be prepared for R 6.4

81294 - RH818645- kexec-tools/mkdumprd: Support line mode terminals
-> Support of line mode terminals to be fixed with R 6.4

xxxxx - RHBZ 825640  - dd: /dev/mem: Operation not permitted
- dd: /dev/mem: Operation not permitted
-> dump over network using ssh gets error - to be fixed with R 6.4
Comment 15 errata-xmlrpc 2012-06-20 10:11:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0885.html
Comment 16 IBM Bug Proxy 2013-01-03 03:40:31 EST
------- Comment From mgrf@de.ibm.com 2013-01-03 08:40 EDT-------
Closing this RHEL 6.3 feature with the following conclusion

Two stage dumper alias kdump got shipped with RHEL 6.3 as technical preview and is full supported with RHEL 6.4.
The R 6.4 tracking bugs are

For fixes
82318 - RH 830272 [6.4 FEAT] Move "Two stage dumper Framework" out of "Tech preview"

For release notes
87053 - RH 881567 [6.4 s390x] Two Stage Dumper framework - Documentation Only [Full Support]

Note You need to log in before you can comment on or make changes to this bug.