Bug 738914 - print null job with lpr makes job stay in queue forever even though ErrorPolicy is set to abort-job
Summary: print null job with lpr makes job stay in queue forever even though ErrorPoli...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cups
Version: 6.0
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-16 02:11 UTC by jas
Modified: 2012-06-20 13:13 UTC (History)
6 users (show)

Fixed In Version: cups-1.4.2-45.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 13:13:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0818 normal SHIPPED_LIVE cups bug fix update 2012-06-19 20:34:20 UTC
CUPS Bugs and Features 4015 None None None Never

Description jas 2011-09-16 02:11:06 UTC
Description of problem:

We just recently upgraded to 6.. Our print server hasn't been updated to 6, and is still using an old LPRng print server at this point.  However, all of our clients are using CUPS.  If a student types "lpr -P<printer>" hits enter, then hits CTRL-D, the job stays in the queue:

prt is ready
Rank    Owner   Job     File(s)                         Total Size
1st     bob     5       (stdin)                         0 bytes

The job is never spooled to the server.

cups error log displays this error twice per minute forever:

E [15/Sep/2011:04:37:13 -0400] [Job 28] Remote host did not accept data file (2)

The queue is setup as with "ErrorPolicy abort-job".

Version-Release number of selected component (if applicable):

1:1.4.2-35.el6_0.1

Steps to Reproduce:
1. lpr
2. CTRL-D
 
Expected results:

Since "ErrorPolicy abort-job" is set, job should disappear from queue and be gone forever.

Additional info:

I know that CUPS probably won't do this for CUPS run queues, but the fact that it knows there is an error, abort-job is set, and it doesn't abort seems like there is an error present.

Comment 11 errata-xmlrpc 2012-06-20 13:13:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0818.html


Note You need to log in before you can comment on or make changes to this bug.