Bug 738936 - [virt-manager] New storage pool can not be added with the whole disk no partition
Summary: [virt-manager] New storage pool can not be added with the whole disk no parti...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-16 03:42 UTC by Daisy Wu
Modified: 2016-04-27 00:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-23 13:45:14 UTC


Attachments (Terms of Use)

Description Daisy Wu 2011-09-16 03:42:09 UTC
Description of problem:
I tried exporting a whole disk (/dev/sdb) to guest but virt-manager does not
allow that until and unless one partitions the disk (create volumes).

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-6.el6
libvirt-0.9.4-11.el6
python-virtinst-0.600.0-3.el6
qemu-kvm-0.12.1.2-2.184.el6.x86_64

#uname -a
Linux localhost.localdomain 2.6.32-193.el6.x86_64.debug #1 SMP Mon Aug 29 11:43:10 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
always

Steps to Reproduce:
1. Make sure have the second disk /dev/sdb, no partition on this disk.
2. Format this disk with type ext3.
3. Add a new storage pool by vitr-manager GUI
   choose type "disk:Pysical Disk Device"
4. Click Forward, choose "/dev/sdb" for Source Path.
5. Click Finish button.
  
Actual results:
Error creating pool: Could not start storage pool: cannot open volume '/dev/sdb1': No such file or directory

Expected results:
New storage pool can be added successfully

Additional info:

Comment 2 RHEL Product and Program Management 2011-10-07 16:11:27 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 4 Cole Robinson 2011-12-09 22:33:53 UTC
I assume this is a libvirt issue, reassigning

Comment 5 Cole Robinson 2016-03-23 13:45:14 UTC
I can't reproduce on f23, so closing


Note You need to log in before you can comment on or make changes to this bug.