Bug 73894 - Does not work when installed with an umask of 077 and messes filesystem
Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-12 19:50 EDT by Enrico Scholz
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 04:39:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-12 19:50:45 EDT
Description of Problem:

Because some php-modules-packages are containing unowned directories,
this directories will be created with the current umask. When having
restrictive administrator settings (umask 077), they will not work.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/lib/php4 /usr/lib/php4/imap.so 
| file /usr/lib/php4 is not owned by any package
| php-imap-4.2.2-11


IMO the best solution is to add

| %dir %{_libdir}/php4

to the %files-section of the main php-package.


Version-Release number of selected component (if applicable):

php-imap-4.2.2-11
php-ldap-4.2.2-11
php-mysql-4.2.2-11
php-odbc-4.2.2-11
php-pgsql-4.2.2-11
php-snmp-4.2.2-11


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that php* is uninstalled completely (rm -rf
   /usr/lib/php4)
3. rpm -U php-4.2.2-11.i386.rpm php-pgsql-4.2.2-11.i386.rpm
4. ls -l /usr/lib/php4
5. start php script using PSQL
6. rpm -e php php-pgsql

Actual Results:

| drwx------    2 root     root         4096 Sep 13 01:32 /usr/lib/php4

at 4; script can not find libraries at 5 and /usr/lib/php4 still
exists after 6.
Comment 1 Joe Orton 2002-12-19 04:39:06 EST
Thanks for the report; fixed in php-4.2.2-11.

Note You need to log in before you can comment on or make changes to this bug.