Bug 738963 - rhncfg-manager fails to "add" configuration file with permissions 000 to configuration channel.
rhncfg-manager fails to "add" configuration file with permissions 000 to conf...
Status: CLOSED DUPLICATE of bug 713098
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
541
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: sat541-triage
  Show dependency treegraph
 
Reported: 2011-09-16 03:26 EDT by Dimitar Yordanov
Modified: 2012-03-22 04:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-15 11:19:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dimitar Yordanov 2011-09-16 03:26:38 EDT
Description of problem:
rhncfg-manager fails to "add" configuration file with permissions 000 to configuration channel.

Version-Release number of selected component (if applicable):
rhncfg-5.9.27-18

How reproducible:
100%

Steps to Reproduce:
1.Register system to Satellite and add  RHN-Tools channel
2.yum insall rhncfg*
3.rhncfg-manager create-channel  test_rhncfg_000_channel
4.echo 'File-Test_000' > /tmp/file_test_000
5.chmod 000 /tmp/file_test_000
6.ls -l /tmp/file_test_000
----------. 1 root root 14 Sep 15 12:15 /tmp/file_test_000
# rhncfg-manager add  -c test_rhncfg_000_channel --dest-file=/etc/file_test_000  /tmp/file_test_000

  
Actual results:
Pushing to channel test_rhncfg_000_channel:
Traceback (most recent call last):
  File "/usr/bin/rhncfg-manager", line 46, in <module>
    sys.exit(Main().main() or 0)
  File "/usr/share/rhn/config_common/rhn_main.py", line 187, in main
    handler.run()
  File "/usr/share/rhn/config_management/rhncfg_add.py", line 111, in run
    delim_end=delim_end)
  File "/usr/share/rhn/config_management/rpc_repository.py", line 145, in put_file
    delim_start=delim_start, delim_end=delim_end)
  File "/usr/share/rhn/config_common/repository.py", line 199, in _make_file_info
    params.update(self.make_stat_info(local_path, file_stat))
  File "/usr/share/rhn/config_common/repository.py", line 104, in make_stat_info
    ret['mode'] = deci_to_octal(ret['mode'] & 07777)
  File "/usr/share/rhn/config_common/repository.py", line 51, in deci_to_octal
    return int(oct_str)
ValueError: invalid literal for int() with base 10: ''

Expected results:
Success.

Additional info:
Comment 1 Jan Pazdziora 2012-03-15 11:19:54 EDT

*** This bug has been marked as a duplicate of bug 713098 ***

Note You need to log in before you can comment on or make changes to this bug.