Bug 738969 - F16 installation media will not EFI boot on MacMini5,1
F16 installation media will not EFI boot on MacMini5,1
Status: CLOSED DUPLICATE of bug 741781
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 03:44 EDT by Jurgen Kramer
Modified: 2011-09-28 11:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-28 11:24:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2011-09-16 03:44:44 EDT
Description of problem:
EFI booting from F16 installation  on the MacMini5,1 no longer works with the latest grub releases (see also BZ #731529)

Version-Release number of selected component (if applicable):
grub-0.97-77.fc16

How reproducible:
always

Steps to Reproduce:
1. Boot from F16 installation media
2. Select EFI boot option

  
Actual results:
The system hangs when selecting the EFI boot option

Expected results:
grub starts normally in EFI mode. No hang

Additional info:
grub-0.97-75 was the last version which worked correctly on the MacMini5,1

Newer macs with Lion use 3 partitions (EFI,system,restore) leaving only one spare MBR partition. Legacy boot / MBR partition scheme is no longer a viable option on macs.
Comment 1 Jurgen Kramer 2011-09-28 09:40:27 EDT
Preliminary test with grub-0.97-78.fc16.x86_64 indicates my EFI boot problems are solved. (tested with efiboot.img written to usb disk with grub.efi from 0.97-78 put in the EFI/BOOT directory).
Comment 2 Peter Jones 2011-09-28 11:24:18 EDT
Given that I'm going to go ahead and call them the same problem (which from a code perspective also seems somewhat likely).

I'm going to close this one dup since there's more testing discussion going on over in the other bug.

*** This bug has been marked as a duplicate of bug 741781 ***

Note You need to log in before you can comment on or make changes to this bug.