Bug 738988 - java.lang.NullPointerException from taskomatic.task.DailySummary
Summary: java.lang.NullPointerException from taskomatic.task.DailySummary
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other
Version: 541
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Matej Kollar
URL:
Whiteboard:
Depends On:
Blocks: sat54-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-16 09:18 UTC by Šimon Lukašík
Modified: 2012-01-31 01:56 UTC (History)
3 users (show)

Fixed In Version: spacewalk-java-1.2.39-110
Doc Type: Bug Fix
Doc Text:
Consequence: If an erratum was scheduled for an update and it was deleted within the same day, DailySummary taskomatic bunch failed with a Null Pointer Exception. Result: DailySummary taskomatic bunch finishes successfully.
Clone Of:
Environment:
Last Closed: 2012-01-31 01:56:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0072 normal SHIPPED_LIVE Red Hat Network Satellite server spacewalk-java bug fix update 2012-01-31 06:55:07 UTC

Description Šimon Lukašík 2011-09-16 09:18:23 UTC
Description of problem:


Version-Release number of selected component (if applicable):
RHN Satellite 5.4.1
spacewalk-java-1.2.39-98.el6sat.noarch

How reproducible:
Deterministic on our internal lab machines.
The reproducer might be dependent on the data thou.

Steps to Reproduce:
1. Visit taskomatic web page:
   /rhn/admin/BunchDetail.do?label=daily-status-bunch
2. Click on 'Single run schedule'
3. watch a taskomatic log
  
Actual results:
INFO   | jvm 1    | 2011/09/16 09:07:25 | 2011-09-16 09:07:25,644 [DefaultQuartzScheduler_Worker-6] ERROR com.redhat.rhn.taskomatic.task.DailySummary - 
INFO   | jvm 1    | 2011/09/16 09:07:25 | java.lang.NullPointerException
INFO   | jvm 1    | 2011/09/16 09:07:25 | 	at java.util.TreeMap.containsKey(TreeMap.java:3928)
INFO   | jvm 1    | 2011/09/16 09:07:25 | 	at com.redhat.rhn.taskomatic.task.DailySummary.renderActionsMessage(DailySummary.java:341)
INFO   | jvm 1    | 2011/09/16 09:07:25 | 	at com.redhat.rhn.taskomatic.task.DailySummary.queueOrgEmails(DailySummary.java:161)
INFO   | jvm 1    | 2011/09/16 09:07:25 | 	at com.redhat.rhn.taskomatic.task.DailySummary.execute(DailySummary.java:99)
INFO   | jvm 1    | 2011/09/16 09:07:25 | 	at com.redhat.rhn.taskomatic.task.RhnJavaJob.execute(RhnJavaJob.java:80)
INFO   | jvm 1    | 2011/09/16 09:07:25 | 	at com.redhat.rhn.taskomatic.TaskoJob.execute(TaskoJob.java:168)
INFO   | jvm 1    | 2011/09/16 09:07:25 | 	at org.quartz.core.JobRunShell.run(JobRunShell.java:216)
INFO   | jvm 1    | 2011/09/16 09:07:25 | 	at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:549)


Expected results:
None traceback

Additional info:
This is a regression against stock RHN Satellite 5.4.1.

Comment 3 Tomas Lestach 2011-09-16 09:55:47 UTC
You're right, Simon - on a fresh RHN Satellite 5.4.1+ installation I do not see the problem.

Comment 5 Tomas Lestach 2011-10-06 15:41:15 UTC
It seems that, "Errata Update" ActionMessage refers to an erratum, that was deleted in the mean time.

spacewalk.git: f263526ccde3f7aa019616b37cf2331187bd0f93

Comment 8 Tomas Lestach 2012-01-04 17:35:44 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Consequence:
If an erratum was scheduled for an update and it was deleted within the same day, DailySummary taskomatic bunch failed with a Null Pointer Exception.
Result:
DailySummary taskomatic bunch finishes successfully.

Comment 11 errata-xmlrpc 2012-01-31 01:56:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0072.html


Note You need to log in before you can comment on or make changes to this bug.