Bug 738989 - iscsiuio: segfault at 2cf ip 00007fa3b57c17b1 sp 00007fa3b5422dc0 error 4 in libpthread-2.12.so
Summary: iscsiuio: segfault at 2cf ip 00007fa3b57c17b1 sp 00007fa3b5422dc0 error 4 in ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iscsi-initiator-utils
Version: 6.2
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Chris Leech
QA Contact: Martin Hoyer
URL:
Whiteboard:
Depends On:
Blocks: 767187 1392437
TreeView+ depends on / blocked
 
Reported: 2011-09-16 09:18 UTC by Gris Ge
Modified: 2017-12-06 11:40 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1392437 (view as bug list)
Environment:
Last Closed: 2017-12-06 11:40:21 UTC


Attachments (Terms of Use)
iscsiuio crash file (24.56 KB, application/x-gzip)
2015-09-30 09:46 UTC, Anugraha Sinha
no flags Details

Description Gris Ge 2011-09-16 09:18:49 UTC
Description of problem:

Got segfault when logout iscsi node.

kernel: iscsiuio[13991]: segfault at 2cf ip 00007fa3b57c17b1 sp 00007fa3b5422dc0 error 4 in libpthread-2.12.so[7fa3b57b5000+17000]

Back trace:
====
#0  pthread_cancel (th=18446744073709551615) at pthread_cancel.c:35
#1  0x000000000040f663 in iscsid_cleanup () at iscsid_ipc.c:805
#2  0x0000000000405082 in cleanup () at main.c:106
#3  0x00000000004051d8 in signal_handle_thread (arg=0x0) at main.c:159
#4  0x00007ff565f4c7e1 in start_thread (arg=0x7ff565bb3700) at pthread_create.c:301
#5  0x00007ff565c9a8ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
====

Core dump could be download from 
http://lacrosse.corp.redhat.com/~fge/tmp/iscsiuio_core_dump_iscsi-initiator-utils-6.2.0.872-25.el6

Version-Release number of selected component (if applicable):
iscsi-initiator-utils-6.2.0.872-25.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. iscsi -m node --targetname <tgt_ip> --logout
  
Actual results:
segfault

Expected results:
no segfault

Additional info:
beaker job /kernel/storage/iscsi/iscsi-chap can be used for testing.

Comment 1 Mike Christie 2011-09-17 04:20:31 UTC
Note. I checked this here with .26 and the 185 kernel and it seems to be working for me.

Eddie, have you seen this one before?

Comment 2 Eddie Wai 2011-09-17 06:45:27 UTC
I can't seem to access the server containing the core dump at the moment.  The lacrosse.corp.redhat.com URL seems to be unreachable for me.  

Broadcom PQA has tested with various rhel62 kernels including the alpha iso with open-iscsi versions 22/25/26 and has not yet able to see this issue.  I personally also have not yet seen this particular segfault either.

The procedure described suggests the problem should be seen 100% by just doing a simple logout.  Are there more to the test setup which we need to be aware of? Can we get more info like target type, network info, node info, etc so we can do a better job at the repro?

The segfault bt looks to be related to glibc's libpthread 2-12.  In addition to the core dump, is it possible to also put iscsiuio to debug mode '-d 99' and obtain the /var/log/iscsiuio.log?

Thanks,
Eddie

Comment 5 Mike Christie 2012-05-02 21:40:45 UTC
I am pretty sure this was fixed. I think it was caused when I did not merge some patches up correctly. We were segfaulting in a couple places. I am going to close it. If we hit it again we can reopen.

Comment 6 Anugraha Sinha 2015-09-24 04:45:07 UTC
Saw the same core again on our production systems.
Scenario:
1. iscsi session was logged in
2. Logout of that session failed as
[] Error:iscsiadm: could not read session targetname: 5
iscsiadm: could not find session info for session61
iscsiadm: No matching sessions found
Return Code 21:

Thereafter we called, /etc/init.d/iscsid restart

It internally checks for running iscsi sessions, if found it does not shutdown the iscsid & iscsiuio daemon.

However, since restart was called, it executed start again... which did start iscsid & iscsiuio on top of a running daemon as well.

RPM informations:
iscsi-initiator-utils-6.2.0.873-13
Base RHEL :
RHEL 6.6

Comment 7 Martin Hoyer 2015-09-24 07:45:04 UTC
Reopening as it seems to be still reproducible on RHEL-6.6.

Comment 9 Anugraha Sinha 2015-09-30 09:46:14 UTC
Created attachment 1078576 [details]
iscsiuio crash file

Adding a iscsiuio crash file for reference.

Comment 10 Manish Singh 2015-10-01 01:58:42 UTC
Please find below iscsid messages during restart of daemon, a segfault occurred in iscsiuio.

Sep 22 06:48:10 HN0101 iscsid: iscsid shutting down.
Sep 22 06:48:10 HN0101 kernel: __ratelimit: 115 callbacks suppressed
Sep 22 06:48:10 HN0101 kernel: iscsiuio[26441]: segfault at 2cf ip 0000003081c0c9a1 sp 00007feeb8406dc0 error 4 in libpthread-2.12.so[3081c00000+17000]
Sep 22 06:48:10 HN0101 kernel: iscsi: registered transport (iser)
Sep 22 06:48:10 HN0101 iscsid: iSCSI logger with pid=27887 started!
Sep 22 06:48:11 HN0101 iscsid: iSCSI daemon with pid=27888 started!
Sep 22 06:48:11 HN0101 iscsid: could not read session targetname: 5
Sep 22 06:48:11 HN0101 iscsid: could not find session info for session61

Comment 13 Jan Kurik 2017-12-06 11:40:21 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.