Bug 738995 - cyrus-imapd downgrade selinux test fail
Summary: cyrus-imapd downgrade selinux test fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy
Version: 5.7
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On: 738994
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-16 09:43 UTC by Juraj Marko
Modified: 2015-09-01 03:38 UTC (History)
3 users (show)

Fixed In Version: selinux-policy-2.4.6-328.el5
Doc Type: Bug Fix
Doc Text:
Clone Of: 738994
Environment:
Last Closed: 2013-01-08 03:31:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0060 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2013-01-08 08:27:19 UTC

Description Juraj Marko 2011-09-16 09:43:58 UTC
+++ This bug was initially created as a clone of Bug #738994 +++

Description of problem:
Running: /sbin/ausearch -sv no -m AVC -ts 09/15/2011 15:41:32 SELinux Check: FAIL SELinux AVC messages found: type=1400 audit(1316115719.288:35518): avc: denied { name_bind } for pid=31435 comm="cyrus-master" src=119 scontext=unconfined_u:system_r:cyrus_t:s0 tcontext=system_u:object_r:innd_port_t:s0 tclass=tcp_socket

Version-Release number of selected component (if applicable):
Name       : selinux-policy
Arch       : noarch
Version    : 2.4.6
Release    : 316.el5

How reproducible:
50%

Steps to Reproduce:
1. tps-rhnqa on cyrus-imapd
  
Actual results:
AVC messages found

Expected results:
no AVC messages found

Additional info:
Same on rhel6

Comment 1 Daniel Walsh 2011-09-16 15:30:08 UTC
Why is cyrus-master trying to bind to port 119?  Is this something local to the
test?

Comment 6 RHEL Product and Program Management 2012-05-29 12:58:14 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 12 errata-xmlrpc 2013-01-08 03:31:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0060.html


Note You need to log in before you can comment on or make changes to this bug.