Bug 738999 - Error deleting a virtual server profile: column "confirmed" is of type smallint but expression is of type boolean
Summary: Error deleting a virtual server profile: column "confirmed" is of type smalli...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 1.5
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space16
TreeView+ depends on / blocked
 
Reported: 2011-09-16 09:53 UTC by Holger Schmitt
Modified: 2011-12-22 16:48 UTC (History)
1 user (show)

Fixed In Version: spacewalk-backend-1.6.39-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-22 16:48:56 UTC


Attachments (Terms of Use)
Tomcat log (9.36 KB, text/plain)
2011-09-16 09:53 UTC, Holger Schmitt
no flags Details

Description Holger Schmitt 2011-09-16 09:53:46 UTC
Created attachment 523533 [details]
Tomcat log

When I try to delete the profile of a virtual server an internal error occurre.


Version-Release number of selected component (if applicable):
- Spacewalk 1.5
- on Scientific Linux 6 X86_64
- Postgresql DB


How reproducible:
On every try to delete the server profile

Steps to Reproduce:
1. On Spacewalk web frontent click on server profile
2. Click on "delete system"
3. Confirm with "Delete Profile"
  
Actual results:
- Website: InternalServer Error 
- Tomcat log: ERROR: column "confirmed" is of type smallint but expression is of type boolean


Expected results:
- Deletion of the selected server profile


Additional info:
- See attachment for tomcat log

Comment 1 Michael Mráka 2011-10-07 07:54:44 UTC
Hi Holger,

I can't reproduce the bug.

What's exactly 'a virtual server'? Is it a system (registered to spacewalk) with virtualization entitlement? Or virtualization platform entitlement? Or is it a virtual guest? Should the host on which the guest is running be also managed by spacewalk?

Comment 2 Michael Mráka 2011-11-11 14:19:38 UTC
Reproducer:
1) register virtual host to spacewalk
2) register a guest running on this host
3) check Systems -> <virt-host> -> Virtualization whether spacewalk know about host<->guest relation
4) click on guest and "delete host"

Comment 3 Michael Mráka 2011-11-18 12:14:13 UTC
Fixed in spacewalk naster by 
commit 50eea0912d7d1fefe970968d5885f8982ff3502d
    738999 - VirtualInstance.confirmed is number not boolean
commit 36208823bf8ecda8f4bc1376be4e8e69f4e0f2a6
    738999 - aliases in update don't work
    fixing
    [Fri Nov 11 08:38:15 2011] [error] SQL Error generated: ('column "rvii" of relation 
    virtualinstanceinfo" does not exist\\nLINE 3:             SET rvii.state=(\\n
                 ^\\n', 0, '\\n            UPDATE rhnVirtualInstanceInfo rvii\\n
    SET rvii.state=(\\n                SELECT rvis.id \\n                FROM rhnVirtual
    anceState rvis\\n                WHERE rvis.label=%(state)s\\n            )\\n
      WHERE\\n                rvii.instance_id IN (\\n                    SELECT rvi.id\
                      FROM rhnVirtualInstance rvi\\n                    WHERE rvi.confir
    0)\\n        ')

Comment 4 Milan Zázrivec 2011-12-22 16:48:56 UTC
Spacewalk 1.6 has been released.


Note You need to log in before you can comment on or make changes to this bug.