Bug 739035 - Toggling "Wired" to off in gnome shell "panel icon" doesn't work
Summary: Toggling "Wired" to off in gnome shell "panel icon" doesn't work
Keywords:
Status: CLOSED DUPLICATE of bug 747302
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 759039 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-16 11:22 UTC by Mads Kiilerich
Modified: 2011-12-02 13:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-02 13:07:50 UTC


Attachments (Terms of Use)

Description Mads Kiilerich 2011-09-16 11:22:43 UTC
Toggling the wired network to off doesn't stop the network connection. ifconfig still shows it as UP and has an IP addresss. "Network Settings" also shows that it really is on.

Setting the wired connection to OFF in "Network Settings" do stop the IPv4 connection - but the interface stays UP and keeps its (unused and not configured by my) IPv6 address. I would expect that setting wired connection to OFF really took the whole device down. As I understand the data model and the user interface it is the device that is disabled, not the IP address.

I don't know if this is one or two issues.

NetworkManager-0.9.0-2.fc16.i686
kernel-PAE-3.1.0-0.rc6.git0.2.1.fc16.i686

Comment 1 Frederic Kerneuzet 2011-10-26 11:58:36 UTC
Using Fedora 16 beta for few days at work, I have almost the same issue, except that for me, it works well through the network manager itself.

It doesn't work only using the applet ON/OFF button.

As I spend my time switching from wired connection to wireless one, it's not efficient for me :D

Comment 2 Aaron Sowry 2011-11-16 12:05:02 UTC
Here's the relevant traceback from .xsession-errors:


    JS ERROR: !!!   Exception was: Error: Error invoking NMClient.disconnect: Invalid callback given for argument callback
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = '"gjs_throw"'
    JS ERROR: !!!     stack = '"("Error invoking NMClient.disconnect: Invalid callback given for argument callback")@gjs_throw:0
()@/usr/share/gnome-shell/js/ui/status/network.js:371
([object _private_Clutter_Event])@/usr/share/gnome-shell/js/ui/status/network.js:232
([object _private_Shell_GenericContainer],[object _private_Clutter_Event])@/usr/share/gnome-shell/js/ui/popupMenu.js:81
"'
    JS ERROR: !!!     message = '"Error invoking NMClient.disconnect: Invalid callback given for argument callback"'


...and a comment from the upstream bug report:

>For some weird reason, nm_device_disconnect @callback is not marked
>(allow-none) in the gir file shipped by the Fedora package, and probably the
>Ubuntu one as well. It is correclty marked as such in master and in the latest
>release of NetworkManager.
>(This means that calling device.disconnect(null) fails, making the switch
>useless).
>You should move this bug downstream and ask for a newer version of libnm-glib.

Comment 3 Volker Sobek 2011-12-01 11:34:17 UTC
Quote from https://bugzilla.gnome.org/show_bug.cgi?id=665112#c6:

> Ow... this is a NetworkManager bug, which was fixed not long ago. You should
> move this bug downstream and ask for an updated version, including the changes
> in git commit a7f7e808.
> (The first release to include that change is 0.9.2, which you can find packaged
> for F16 in koji but not yet in updates. This means that this bug could be
> already resolved in the next update to NetworkManager)

Comment 4 Kamil Páral 2011-12-01 12:27:49 UTC
*** Bug 759039 has been marked as a duplicate of this bug. ***

Comment 5 Jirka Klimes 2011-12-02 13:07:50 UTC

*** This bug has been marked as a duplicate of bug 747302 ***


Note You need to log in before you can comment on or make changes to this bug.