Bug 739041 - [abrt] quodlibet-2.3-1.fc14: _base.py:87:reset:AttributeError: 'GStreamerPlayer' object has no attribute '_source'
Summary: [abrt] quodlibet-2.3-1.fc14: _base.py:87:reset:AttributeError: 'GStreamerPlay...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: quodlibet
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: hannes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2da59b06
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-16 11:44 UTC by Martin Nyhus
Modified: 2012-01-07 17:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-07 17:02:37 UTC


Attachments (Terms of Use)
File: backtrace (550 bytes, text/plain)
2011-09-16 11:45 UTC, Martin Nyhus
no flags Details

Description Martin Nyhus 2011-09-16 11:44:59 UTC
abrt version: 1.1.18
architecture: x86_64
cmdline: python /usr/bin/quodlibet
component: quodlibet
executable: /usr/bin/quodlibet
kernel: 2.6.35.14-96.fc14.x86_64
package: quodlibet-2.3-1.fc14
reason: _base.py:87:reset:AttributeError: 'GStreamerPlayer' object has no attribute '_source'
release: Fedora release 14 (Laughlin)
How to reproduce: I haven't been able to reproduce this, but based on the backtrace it seems likely that the crash happened because I pressed play (keyboard button) continously while quodlibet was starting.
time: 1316173361
uid: 500

backtrace
-----
_base.py:87:reset:AttributeError: 'GStreamerPlayer' object has no attribute '_source'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/quodlibet/qltk/mmkeys_.py", line 26, in __play_pause
    player.reset()
  File "/usr/lib/python2.7/site-packages/quodlibet/player/_base.py", line 87, in reset
    self._source.reset()
AttributeError: 'GStreamerPlayer' object has no attribute '_source'

Local variables in innermost frame:
self: <GStreamerPlayer object at 0x305cf50 (quodlibet+player+gstbe+GStreamerPlayer at 0x2a64860)>

Comment 1 Martin Nyhus 2011-09-16 11:45:02 UTC
Created attachment 523545 [details]
File: backtrace

Comment 2 hannes 2011-09-17 10:36:57 UTC
Thanks for the report, I forwarded it to the upstream bug tracker.
http://code.google.com/p/quodlibet/issues/detail?id=810

Comment 3 hannes 2011-12-19 10:36:25 UTC
It's fixed upstream and the fix should be part of the next quodlibet release.


Note You need to log in before you can comment on or make changes to this bug.