This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 739072 - libreoffice-langpack-lt-3.3.3.1-5.fc15.x86_64 contains Latvian language (lv) not Lithuanian (lt)
libreoffice-langpack-lt-3.3.3.1-5.fc15.x86_64 contains Latvian language (lv) ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 09:53 EDT by Vytas
Modified: 2011-10-03 07:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-03 07:03:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (6.34 KB, image/png)
2011-09-22 05:44 EDT, Vytas
no flags Details

  None (edit)
Description Vytas 2011-09-16 09:53:03 EDT
Description of problem:
libreoffice-langpack-lt-3.3.3.1-5.fc15.x86_64 contains Latvian language (lv) not Lithuanian (lt)

Version-Release number of selected component (if applicable):
3.3.3.1-5.fc15.x86_64

How reproducible:
100%

Steps to Reproduce:
1. yum install libreoffice-langpack-lt
2. tools -> Language -> (any)
  
Actual results:
Latvian language option!?

Expected results:
Lithuanian language option

Additional info:
no
Comment 1 David Tardon 2011-09-16 11:17:25 EDT
I took a couple random strings from the lt translation, pasted them into http://translate.google.com/#auto|en and they were invariably recognized as Lithuanian. So I really am not sure what your problem is?
Comment 2 Vytas 2011-09-17 13:15:34 EDT
Problem 2 is that Latvian and Lithuanian are two different languages, but perfect google translate can not translate to one from other or even find any difference between them. I do not care much about this one.

Main problem is that Libreoffice on Fedora 15 can not check Lithuanian spelling.
Here some Lithuanian text for example:
http://lt.wikipedia.org/wiki/Lietuva
You can induce errors and try check it.

Here very similar text in Latvian language:
http://lv.wikipedia.org/wiki/Lietuva

Lietuvas Republika (Latvian) translate -> Lietuvos Republika (Lithuanian).

If you have any more questions feel free to ask. ;)
Comment 3 David Tardon 2011-09-18 07:21:59 EDT
I still do not understand your problem. I tried two things (after installing libreoffice-langpack-lt)

1. run writer in default (en) locale and set document language to lt (tools->language->for all text->more, select Lithuanian in "Default languages for documents")

2. run writer in lt locale (LC_ALL=lt_LT oowriter)

Then I pasted some text from the lt wiki page. Spell checking worked in both cases (in case 2 by default, without the need to change document language, as expected). After that, I also tried to paste some text from the other (lv) wiki page to the same document, and spell checker marked a lot of spelling problems in both cases.
Comment 4 Vytas 2011-09-20 08:49:23 EDT
I tired then on my other 32bit system all oki then too. 
I will double check my 64bit system settings, sorry if my mistake.
Or this can be 64bit only bug if you tired 32bit too.
Comment 5 Caolan McNamara 2011-09-20 09:10:29 EDT
What *exactly* is the problem, maybe attach a screenshot of the problem ?

First I thought this was "incorrect translations", now I wonder if its "incorrect default spellchecking language".

Though hunspell-lt does appear to be Lithuanian, i.e. /usr/share/doc/hunspell-lt-1.2.1/README.EN so it doesn't look like it could be a "Latvian dictionary installed as Lithuanian", so it might depend on what what format->character is saying is the language of inputted text
Comment 6 Vytas 2011-09-22 05:44:34 EDT
Created attachment 524372 [details]
screenshot

Here image, I partially fixed it I think something did with more... or options..., but still somehow I got Latvian language, and at first it was just Latvian and I do not want it at all. And I do not have any *-lv package.
Comment 7 Caolan McNamara 2011-09-22 06:32:39 EDT
Is the screenshot you attach a screenshot of the problem. What is wrong in that picture ?


Here are some more questions in case its all about your default document language.

a) what's the output of 
locale (type it into a terminal)
b) what does (in e.g. writer)
tools->options->language settings->languages->"default languages for document" say ?

That will tell us if your default document language is correct.

Any document can have a different language set for a document, and in writer a paragraph can have a different language from the rest of the document and so on. So it might be the case that opening a particular existing Latvian document will obviously set the language of the text of that document to Latvian, or some document or format might have a bug in it.

Basically, we need a step-by-step of the exact problem.
Comment 8 Vytas 2011-09-24 08:08:39 EDT
In picture wrong is that I have Latvian language.
Before (right after libreoffice-langpack-lt-3.3.3.1-5.fc15.x86_64 install) there was no Lithuanian language too, but I fixed this somehow.

locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

>tools->options->language settings->languages->"default languages for document"
say ?
I changed that to Lithuanian few days ago. This fixed the problem partially at least I have Lithuanian as I want.

>So it might be the case that opening a particular existing Latvian document
I as sure I never used documents in Latvian language.
Comment 9 Caolan McNamara 2011-09-26 06:41:01 EDT
I continue to fail to understand.

A langpack is a language pack which provides translations.

The picture in #6 is just a picture of a drop drop menu that shows the language that some text is set to, and that drop down just says "Lithuanian" (in English), i.e. the text that was selected was Lithuanian.

Is the problem that the "guess the language feature" suggested that some text might be Latvian ?

From your locale settings you've got a system which defaults to English USA for everything. I could *imagine* that you were fighting your settings and selecting all your English text and using the guess-the-correct-language feature, and perhaps it suggested Latvian.
Comment 10 Caolan McNamara 2011-10-03 07:03:47 EDT
I're stumped. Seems to all work ok for us. I checked the "guess the language" feature for lv and lt in case it was that, and that seems to work ok for me too with samples from the translated UDHR (UN Human Declaration of Human Rights) and it seems to get the right language there too.

Note You need to log in before you can comment on or make changes to this bug.