Bug 739078 - Booting to runlevel 3 failed
Booting to runlevel 3 failed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 10:13 EDT by Tadej Janež
Modified: 2011-09-19 17:23 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-19 17:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tadej Janež 2011-09-16 10:13:04 EDT
Description of problem:
I followed this test day:
https://fedoraproject.org/wiki/Test_Day:2011-09-07_Radeon
and performed this test case:
https://fedoraproject.org/wiki/QA:Testcase_radeon_restartx

I appended " 3" to the kernel options line and booted the system. The system
failed to boot into text mode and show a text-mode login prompt.

Version-Release number of selected component (if applicable):
Special version of F-16 alpha:
http://adamwill.fedorapeople.org/graphics_test_week_20110905/graphics_test_week-20110905-x64.iso

How reproducible:
Always.

Steps to Reproduce:
1. Append " 3" to the kernel options.
2. Boot the system.
  
Actual results:
The system doesn't present a text-mode login prompt. Instead, a "Text Mode Setup Utility 1.19.11" is shown with the following options:
- Authentication configuration
- Firewall configuration
- Keyboard configuration
- Network configuration

Pressing Escape switches to "RHGB"-like graphical boot screen, with the Fedora logo almost completely "full". Pressing Escape again, switches back to the
"Text Mode Setup Utility".

Expected results:
The system should present a text-mode login prompt.
Comment 1 Michal Schmidt 2011-09-16 10:56:02 EDT
Adding Adam to CC because it is his ISO image.
Adam, you probably don't want to run firstboot-text.service on the live CD...
Comment 2 Adam Williamson 2011-09-16 14:08:50 EDT
nothing I did to cause it, I just use the stock kickstarts. It's likely this bug is in official builds too. Please check that. If it's not, then close the bug, as the test day builds have no official status and are only there for test day testing.
Comment 3 Bill Nottingham 2011-09-19 15:32:22 EDT
In any case, this isn't a systemd issue. Moving to spin-kickstarts, although could be in firstboot itself if the service file is wrong.
Comment 4 Adam Williamson 2011-09-19 17:23:09 EDT
I tested this several times with Beta RC1 images today and couldn't hit it, but someone else was saying they didn't see a login on tty1 with a nightly. I suspect the firstboot update in the side repo for Beta is fixing it. note we're likely going to simply kill firstboot-text at least for Beta, to workaround https://bugzilla.redhat.com/show_bug.cgi?id=737118 . I'm gonna close this for now.

Note You need to log in before you can comment on or make changes to this bug.