Bug 739090 - plugin config for a group w/ 1000+ members fails to load due to "ORA-01795: maximum number of expressions in a list is 1000" error
Summary: plugin config for a group w/ 1000+ members fails to load due to "ORA-01795: m...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Core UI
Version: 4.1
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: rhq-ora-in-clause jon3 jon30-perf
TreeView+ depends on / blocked
 
Reported: 2011-09-16 14:43 UTC by Ian Springer
Modified: 2013-08-06 00:40 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-02-07 19:25:37 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 737193 None None None Never
Red Hat Bugzilla 737196 None None None Never

Internal Trackers: 737193 737196

Description Ian Springer 2011-09-16 14:43:46 UTC
This is all that's logged to the Server log (no stack trace):

10:37:40,012 WARN  [JDBCExceptionReporter] SQL Error: 1795, SQLState: 42000
10:37:40,012 ERROR [JDBCExceptionReporter] ORA-01795: maximum number of expressions in a list is 1000


There is no error displayed in the GUI, but the config editor never loads. The only content for the subtab remains a button bar with a grayed out Save button.

Comment 1 John Mazzitelli 2011-09-30 19:27:56 UTC
I'm not seeing this and I have a compat group of 1020 members. However, this does cause timeouts as per bug #737196 and I will try to work on speeding that up.

Comment 2 John Mazzitelli 2011-09-30 19:30:16 UTC
lowering this to medium because I am not seeing this, however, I am going to leave it open. Once the issues are done with the plugin config views and we are sure this issue doesn't appear or re-appear, we can close it.

Comment 3 John Mazzitelli 2011-10-06 13:50:27 UTC
I have a unit test that tests for this - see bug #737196. This should no longer be a problem.

Comment 4 Mike Foley 2011-10-06 17:49:27 UTC
performed additional functional regression testing around groups.

Comment 5 Mike Foley 2012-02-07 19:25:37 UTC
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE


Note You need to log in before you can comment on or make changes to this bug.