Bug 7391 - message flag setting
message flag setting
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: pine (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-28 12:19 EST by osman
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-17 14:53:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description osman 1999-11-28 12:19:55 EST
It seems that the version "pine-4.20-2.i386.rpm" doesn't unset the unseen flag on messages properly.
When I have a new messae in a folder or system-inbox and I read it, it should reset that flag to seen.
But when I quit pine and re-enter pine again that message is sowing up as unseen.
The same symptom is also occuring when I read unseen msg's and return
to pine after quiting.
The last version didn't had that problem...
I don't recall If I upgraded from 4.10-x or 4.20-1 ...
Comment 1 Riley H Williams 1999-11-28 17:39:59 EST
Have you checked that you don't have a stale lock file floating around
somewhere? I had this very problem a while back, and it proved to be because
netlag had killed my telnet, causing pine to abort abnormally, and when I next
connected and ran pine, the stale lock flag resulting from the crash held the
PID of another user's pine process, causing pine to go into READ-ONLY mode.

I don't know whether the fact that the PID had been reused was relevant, but
certainly the behaviour was there...
Comment 2 osman 1999-11-29 08:26:59 EST
No I don't think it has to do with a lock file because then you will be warned
that pine is in READ-ONLY mode. Because I don't get that kind of message or
indication I don't think that's the case.
Furthermore it happens in ALL folders so...
Comment 3 Trond Eivind Glomsrxd 2000-04-17 14:53:59 EDT
This seems to be fixed in the ones included in Red Hat Linux 6.2

Note You need to log in before you can comment on or make changes to this bug.