Bug 739134 - GRUB 2 has extraneous menu entries after installing Xen
GRUB 2 has extraneous menu entries after installing Xen
Status: CLOSED DUPLICATE of bug 738085
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 11:40 EDT by W. Michael Petullo
Modified: 2011-09-20 22:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-20 22:28:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2011-09-16 11:40:14 EDT
Description of problem:
I have been testing Fedora 16 Beta RC1's ability to boot Linux in Xen Domain 0. I have found that, in the presence of the Xen hypervisor, grub2-mkconfig creates several extraneous menu entries

Version-Release number of selected component (if applicable):
grub2-1.99-6.fc16.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora Beta RC1
2. Install Xen
3. Update to grub2-1.99-6.fc16.x86_64
4. Run grub2-mkconfig -o /boot/grub2/grub.cfg
  
Actual results:
When I reboot, I get the following menu entries:

Fedora Linux, with Linux 3.1.0-0.rc6.git0.0.fc16.x86_64
Fedora Linux, with Linux 3.1.0-0.rc6.git0.0.fc16.x86_64 (recovery mode)
Xen 4.1
Xen 4.1.1
Xen syms-4.1.1
Xen xen

The Xen entries use sub-entries, one for regular and one for recovery mode. Xen.4.1 -> Fedora Linux, with Linux 3.1.0-0.rc6.git0.0.fc16.x86_64 boots fine.

Expected results:
The menu should contain:

Fedora Linux, with Linux 3.1.0-0.rc6.git0.0.fc16.x86_64
Fedora Linux, with Linux 3.1.0-0.rc6.git0.0.fc16.x86_64 (recovery mode)
Xen 4.1.1

Additional info:
Comment 1 Fedora Admin XMLRPC Client 2011-09-16 15:08:38 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Jerry Amundson 2011-09-20 22:28:27 EDT

*** This bug has been marked as a duplicate of bug 738085 ***

Note You need to log in before you can comment on or make changes to this bug.