Bug 739165 - ibus not playing well with more than one system keyboard layout
ibus not playing well with more than one system keyboard layout
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 12:13 EDT by Jens Petersen
Modified: 2011-10-08 14:03 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-1.4.0-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-03 13:58:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2011-09-16 12:13:57 EDT
Description of problem:
If one enables more than one keyboard layout in gnome
before activating ibus with im-chooser,
then ibus lists the keyboards (which is good)
but switching between the layouts seems only possible
via the keyboard layout icon, not the ibus menu.
Switching layout from the ibus menu causes the layout
to change momentarily and then revert back to the current one
almost immediately.

Version-Release number of selected component (if applicable):
ibus-1.3.99.20110817-5.fc16
(all packages updated to latest current F16 + updates-testing)

How reproducible:
100%

Steps to Reproduce:
1. Make sure ibus is off (and perhaps no IMEs added)
2. add one or more keyboard layout in the gnome control kbd layout configuration
3. start ibus from im-chooser
4. click on ibus icon to show menu
5. select other keyboard layout
6. check layout indicator icon

Actual results:
4. gnome layouts listed in ibus menu (this is good I think)
5. layout changes but then gnome switches it back again and override ibus
   ibus menu now highlighting the newly selected layout
   although the keyboard indicator (and kbd) are back on the original layout.
6. With two layouts at least clicking the layout indicator still works to
   change the layout.  With 3 layouts I saw the keyboard indicator not
   respond to clicks with ibus running. 

Expected results:
5. gnome and ibus layout should be in sync and agree
Comment 1 fujiwara 2011-09-27 05:20:46 EDT
In the previous gnome-shell, I removed the focus handling in shell icon menu as a workaround so that shell icon menu doesn't take up the input focus on the text application.
As you knew, the ibus menu didn't close automatically due to that workaround.
Since the API is changed in gnome-shell 3.1.91, if I apply the workaround, shell icon menu is no longer accessible by mouse so I dropped my workaround in the latest gnome-shell.

Then current gnome-shell takes up the input focus and ibus doesn't set the XKB for the target application in this bug.

I will apply another workaround but unfortunately it won't fix all issues against the workaround of removing the focus handling.
Comment 2 Fedora Update System 2011-09-28 07:36:30 EDT
ibus-1.4.0-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-1.4.0-2.fc16
Comment 3 Fedora Update System 2011-09-28 07:36:49 EDT
ibus-1.4.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-1.4.0-2.fc15
Comment 4 Fedora Update System 2011-09-28 14:54:34 EDT
Package ibus-1.4.0-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.4.0-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ibus-1.4.0-2.fc16
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2011-10-03 13:58:29 EDT
ibus-1.4.0-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2011-10-08 14:03:24 EDT
ibus-1.4.0-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.