Bug 739168 - Remove bea-stax-api (and perl) dependency.
Summary: Remove bea-stax-api (and perl) dependency.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rhino
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-16 16:52 UTC by Matěj Cepl
Modified: 2018-04-11 14:43 UTC (History)
3 users (show)

Fixed In Version: rhino-1.7R3-2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-02 18:17:05 UTC


Attachments (Terms of Use)
suggested patch (2.12 KB, patch)
2011-09-16 16:52 UTC, Matěj Cepl
no flags Details | Diff
rebased patch on top of rhino-1.7R3-1 (2.01 KB, patch)
2011-09-20 23:54 UTC, Matěj Cepl
no flags Details | Diff
rebased patch on top of rhino-1.7R3-1 (and also bump the release) (2.70 KB, patch)
2011-09-21 00:00 UTC, Matěj Cepl
no flags Details | Diff

Description Matěj Cepl 2011-09-16 16:52:12 UTC
Created attachment 523585 [details]
suggested patch

See attached (applies on the top of the current Rawhide build). I don't think we need to require bea-stax-api which is now part of OpenJDK.

And now, we don't have to use perl, when we have sed ;)

Comment 1 Alexander Kurtakov 2011-09-16 18:01:05 UTC
Only comment is about building with no-xmlbean. Why?
Other than that it looks good.

Comment 2 Matěj Cepl 2011-09-16 19:51:01 UTC
This is the explanation I've got on #ringojs channel:

<earl> mcepl: you can just compile with no-xmlbeans=1 to skip the old xmlbeans stuff
<mcepl> earl: and what would it do?
<earl> it won't build the legacy e4x impl
<mcepl> legacy? So, what it would build? no E4X?
<earl> the new non-xmlbeans-based e4x impl
<mcepl> ooooh
<mcepl> want
<earl> ant jar -Dno-xmlbeans=1
<earl> (or set this in a custom build.local.properties)
<mcepl> it's easier to do it with a parameter in spec file

I was also pointed to https://github.com/mozilla/rhino/blob/master/xmlimplsrc/build.xml#L38-41

"no-xmlbeans: Will cause the old, XMLBeans-based implementation of E4X not to be built"

Comment 3 Alexander Kurtakov 2011-09-20 09:32:30 UTC
Should this be closed as duplicate of bug 739211 ?

Comment 4 Matěj Cepl 2011-09-20 14:35:45 UTC
No, each patch deals with a different issue. Of course, I have patches for both.

Comment 5 Matěj Cepl 2011-09-20 23:54:29 UTC
Created attachment 524106 [details]
rebased patch on top of rhino-1.7R3-1

Comment 6 Matěj Cepl 2011-09-21 00:00:11 UTC
Created attachment 524108 [details]
rebased patch on top of rhino-1.7R3-1 (and also bump the release)

Comment 7 Alexander Kurtakov 2011-09-21 14:41:58 UTC
Looks perfect. Please apply.

Comment 8 Fedora Update System 2011-09-22 13:56:13 UTC
rhino-1.7R3-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rhino-1.7R3-2.fc16

Comment 9 Fedora Update System 2011-09-24 20:48:00 UTC
Package rhino-1.7R3-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rhino-1.7R3-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/rhino-1.7R3-2.fc16
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-10-02 18:17:00 UTC
rhino-1.7R3-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.