Bug 739191 - Ceph 0.34 FUSE client freezes 2.6.32-131.12.1.el6.x86_64
Summary: Ceph 0.34 FUSE client freezes 2.6.32-131.12.1.el6.x86_64
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fuse
Version: 6.1
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Carlos Maiolino
QA Contact: Filesystem QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-16 18:11 UTC by Lans Carstensen
Modified: 2016-03-08 07:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-08 07:53:11 UTC


Attachments (Terms of Use)
/var/log/messages and "thread apply all bt full" from cfuse process (10.71 KB, application/x-bzip2)
2011-09-16 18:11 UTC, Lans Carstensen
no flags Details

Description Lans Carstensen 2011-09-16 18:11:52 UTC
Created attachment 523599 [details]
/var/log/messages and "thread apply all bt full" from cfuse process

Description of problem:

During Ceph 0.34 FUSE client testing we caused oddities in current/released RHEL 6.1 kernels.  I'm attaching a simple repro, sysrq+w output from two hangs and one after I killed off the cfuse process the second time, and a "thread apply all bt full" from the cfuse userspace process.  I can often, but not always, recover by kill -9'ing cfuse and umount'ing the cfuse mountpoint.

Version-Release number of selected component (if applicable):

kernel-2.6.32-131.12.1.el6.x86_64
ceph & ceph-fuse 0.34

How reproducible:

100% in my environment

Steps to Reproduce:
1.  Set up a Ceph server, set up a client keyring for client.yourhostname
2.  cfuse /mnt --name=client.yourhostname

while(1)
dd if=/dev/zero of=/mnt/file bs=1M count=1
/bin/rm /mnt/file
end

Actual results:

Files created/removed, then mountpoint hangs and causes other odd kernel lockups.

Expected results:

Files created/removed

Additional info:

Comment 2 Suzanne Yeghiayan 2011-10-06 18:51:43 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.
               
Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 6 Carlos Maiolino 2016-03-07 20:28:12 UTC
I got assigned to this bug, but it's a very old bug.

Lans, can you let me know if you can still reproduce it on newer versions of RHEL6? If so, can you provide kernel stack traces of the hung processes? in the messages file attached, no stack traces from kernel side are available.

Thanks.

Comment 7 Lans Carstensen 2016-03-07 20:56:30 UTC
Wow, this is a blast from the past.  Go ahead and close this as unreproducible, and thanks for following up!

Comment 8 Carlos Maiolino 2016-03-08 07:53:11 UTC
Thanks for the follow up Lans, feel free to re-open it if you step on this bug again.

Cheers


Note You need to log in before you can comment on or make changes to this bug.