This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 73921 - Does not work when installed with an umask of 077 and messes filesystem
Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-RPM2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 09:53 EDT by Enrico Scholz
Modified: 2008-03-07 07:09 EST (History)
3 users (show)

See Also:
Fixed In Version: perl-RPM2-0.67-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 07:09:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 09:53:25 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
them.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/RPM2 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/RPM2/RPM2.bs
| file /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/RPM2 is not owned by any package
| perl-RPM2-0.44-4


Version-Release number of selected component (if applicable):

perl-RPM2-0.44-4


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that perl-RPM2 is uninstalled completely
   (rm -rf /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/RPM2)
3. rpm -U perl-RPM2-0.44-4.*
4. ls -l /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/RPM2
5. start perl script using this module
6. rpm -e perl-RPM2-0.44-4

Actual Results:

| drwx------    2 root     root         4096 Sep 13 15:25 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/RPM2

at 4; script can not find package at 5 and
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/RPM2
still exists after 6.


Additional Information:

When adding

| for i in installarchlib vendorlib; do
| 	eval $(perl "-V:$i")
| 	dir=$(eval echo \$$i)
|
|       echo "%exclude %dir ${dir}"
| 	find "${RPM_BUILD_ROOT}${dir}" -type d -mindepth 1 ! -empty -print |	\
| 		sed "s@^$RPM_BUILD_ROOT@%dir @g"
| done | sort -u >> %{modname}-%{version}-filelist

to the file-finding section in the spec-file, this class of bugs can
be fixed for all perl-XXX packages.
Comment 1 Warren Togami 2005-09-11 07:28:13 EDT
Spec has not been rewritten to modern perl packaging standards, so likely still
affected.
Comment 2 Bill Nottingham 2006-11-22 12:09:59 EST
perl-RPM2 is no longer shipped in any currently maintained Fedora releases. Closing.
Comment 3 Robin Norwood 2006-11-22 12:51:23 EST
Re-opening - there's a request to add this back into extras (bug #184530), but I
want to make sure this bug is fixed first.
Comment 4 Marcela Mašláňová 2008-03-07 07:09:07 EST
Looks like it was fixed in review of this package.

Note You need to log in before you can comment on or make changes to this bug.