Bug 739258 - Graphical firstboot runs, even if /etc/sysconfig/firstboot has RUN_FIRSTBOOT=NO
Graphical firstboot runs, even if /etc/sysconfig/firstboot has RUN_FIRSTBOOT=NO
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
16
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-09-16 18:56 EDT by Jared Smith
Modified: 2013-07-04 08:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-22 17:24:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jared Smith 2011-09-16 18:56:04 EDT
Description of problem:

I installed the LiveCD for Fedora 16 Beta RC1 to a usb key (using livecd-iso-to-disk), and booted off of the USB key.  Graphical firstboot started before GDM, even though /etc/sysconfig/firstboot has RUN_FIRSTBOOT=NO.


Version-Release number of selected component (if applicable):

firstboot-16.3-1.fc16.i686

How reproducible:

Very

Steps to Reproduce:
1. Boot from the Fedora 16 Beta RC1 Live Desktop image
2. Notice that graphical firstboot starts
3. Press Alt-F4 to skip firstboot
4. Go to a TTY, log in, and look at the contents of /etc/sysconfig/firstboot
  
Actual results:

Graphical firstboot started before GDM

Expected results:

Graphical firstboot should not have run

Additional info:

I verified with the QA team in #fedora-qa that they're seeing this too.
Comment 1 Adam Williamson 2011-09-17 03:36:30 EDT
er, you did? I chatted with you a bit, but I didn't say I'm seeing this. I'm not. I tested it, and couldn't get the same thing, either in graphical or text mode. Trying to call firstboot directly also caused it to quit immediately, as it should.

does firstboot run if you simply call it directly?
Comment 2 Adam Williamson 2011-09-21 21:03:39 EDT
Discussed at the 2011-09-21 go/no-go meeting (note: in #fedora-meeting-1),
acting as a blocker review meeting. Agreed to leave this one till Friday, as it's potentially a serious issue, but no-one besides Jared can reproduce it, or see how it could be possible. Jared, please look into this more closely and try to figure out how the check in /etc/init.d/firstboot is being circumvented in your case. thanks!
Comment 3 Martin Gracik 2011-09-22 02:50:51 EDT
You mean firstboot started when you booted the livecd? Not the installed system?
Comment 4 Jared Smith 2011-09-22 17:24:10 EDT
Yes, firstboot started when I booted the LiveCD (before I had a chance to install the system), but I've since re-installed the LiveCD image to my USB key, and am no longer seeing that behavior.  Not sure what (if anything) is different, besides the fact that maybe the SELinux bug was somehow having an effect.  Let's go ahead and close this bug, and I'll re-open it if I can reproduce it in my testing again.

Note You need to log in before you can comment on or make changes to this bug.