Bug 739260 - Evolution doesn't mark messages as replied when sending offline
Summary: Evolution doesn't mark messages as replied when sending offline
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-16 23:57 UTC by Pavel Šimerda (pavlix)
Modified: 2011-09-19 08:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 08:57:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 659440 None None None Never

Description Pavel Šimerda (pavlix) 2011-09-16 23:57:25 UTC
Evolution behaves totally wrong when sending (or outboxing) e-mails offline.

This bug, together with other bugs that keep evolution offline most of the time (namely the bug that evolution doesn't reconnect and the bug that wifi disconnects every 10 minutes).

By the way, going offline (by clicking the status icon or through menu) seems to be broken now (nothing changes after clicking it and choosing „do not synchronize“).

Version-Release number of selected component (if applicable):

evolution-3.0.3-1.fc15.x86_64

How reproducible:

Always (AFAIK)

Steps to Reproduce:
1. Disconnect/go offline (evolution wrongly thinks it's offline most of the time anyway)
2. Send a reply
3. Click the only button available (discard)
4. Connect/go online
5. Look at the original message
  
Actual results:

after 2) a dialog box that cannot be cancelled (to keep the message window open and not to put the message to outbox), which is totally wrong from the UI perspective (the system wants to do something, informs you that it's going to do that but offers no way to stop it)

after 5) the message is not marked as replied... that means you cannot dispatch messages you haven't replied yet, because you don't even know which are already replied and which not


Expected results:

after 2) OK and Cancel buttons, so user can actually choose what to do in this unstandard situation (maybe he wants to change the message when he realizes he's not able to send it now but will have to send it later)

after 5) The message MUST be marked as replied, unless there is some serious
error (and this serious error should be reported!)


Additional info

There are so many serious (and reported) bugs in Evolution that it can't be considered a ready to use software. Maybe there should be some other mail client
made default for new fedora users, or at least they should be warned they're touching something experimental and broken.

Comment 1 Milan Crha 2011-09-19 08:57:19 UTC
Thanks for a bug report. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=659440


Note You need to log in before you can comment on or make changes to this bug.