Bug 739316 - sqlite3 connection component requires libsqlite3.so
Summary: sqlite3 connection component requires libsqlite3.so
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: lazarus
Version: 15
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Joost van der Sluis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-17 14:02 UTC by Heiko Adams
Modified: 2011-09-19 20:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 13:28:09 UTC


Attachments (Terms of Use)

Description Heiko Adams 2011-09-17 14:02:34 UTC
Description of problem:
Lazarus contains a component for using sqlite3 as database backend. This component can't be used because it requires a libsqlite3.so

Version-Release number of selected component (if applicable):
lazarus-0.9.30-1.fc15.i686
sqlite-3.7.5-3.fc15.i686

How reproducible:
allways

Steps to Reproduce:
1. start lazarus
2. create a new project
3. place a sqlite3 connection component on the form
4. set the databasename property
5. set the active property to true
  
Actual results:
"Can not load SQLite client library "libsqlite3.so". Check your installation."

Expected results:
no error should appear

Additional info:

Comment 1 Joost van der Sluis 2011-09-19 13:28:09 UTC
When you, as a developer, want to use sqlite, you should now that you'll have to install sqlite. 

Or else Lazarus has to depend on all packages you can use when you build your own programs. That'll mean it has to depend on almost all other library-packages. That's not doable.

Comment 2 Heiko Adams 2011-09-19 19:07:18 UTC
As you can see in my original post sqlite is installed but the file/symlink libsqlite3.so is missing and for that reason it's impossible to create applications using the sqlit3connection component of lazarus.

IMHO either the component source needs to be patched to search for the correct file or the sqlite3 package needs to create a libsqlite3 symlink.

Comment 3 Joost van der Sluis 2011-09-19 19:25:03 UTC
Sorry, didn't read it well. But you need the sqlite3-devel package.

Comment 4 Heiko Adams 2011-09-19 20:16:40 UTC
So this is a missing dependency of lazarus?


Note You need to log in before you can comment on or make changes to this bug.