Bug 739318 - error: unpacking of archive failed on file /usr/share/groff/site-font: cpio: rename
Summary: error: unpacking of archive failed on file /usr/share/groff/site-font: cpio: ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: groff
Version: rawhide
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Jan Vcelak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 447156
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-17 14:13 UTC by Andre Robatino
Modified: 2013-03-04 01:29 UTC (History)
4 users (show)

Fixed In Version: groff-1.21-5.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-20 09:26:03 UTC


Attachments (Terms of Use)

Description Andre Robatino 2011-09-17 14:13:26 UTC
Description of problem:
While applying the 20110917 Rawhide updates, yum gives the error

  Installing : groff-base-1.21-4.fc17.x86_64                              14/72 
Error unpacking rpm package groff-base-1.21-4.fc17.x86_64
error: unpacking of archive failed on file /usr/share/groff/site-font: cpio: rename

Version-Release number of selected component (if applicable):
1.21-4.fc17.x86_64

Comment 1 Stijn Hoop 2011-09-19 12:06:31 UTC
This is caused by the switch from directory to symlink for the following two paths (bug 447156 ):

/usr/share/groff/site-font
/usr/share/groff/site-tmac

Suggested solution seems to be to add a %pretrans scriptlet.

Comment 2 Jan Vcelak 2011-09-20 09:26:03 UTC
Workaround applied in: groff-1.21-5.fc17


Note You need to log in before you can comment on or make changes to this bug.