Bug 739345 - pylorax throws an exception when used with fedora-logos-16.0.2
pylorax throws an exception when used with fedora-logos-16.0.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-09-17 18:26 EDT by Tim Flink
Modified: 2013-07-04 08:58 EDT (History)
6 users (show)

See Also:
Fixed In Version: lorax-16.4.4-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-25 21:40:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix paths to line up with new fedora-logos (1.00 KB, patch)
2011-09-17 19:16 EDT, Tim Flink
no flags Details | Diff

  None (edit)
Description Tim Flink 2011-09-17 18:26:10 EDT
Description of problem:

When used with fedora-logos-16.0.2, lorax throws the following exception:
writing .discinfo file
Traceback (most recent call last):
  File "/usr/bin/pungi", line 222, in <module>
    main()
  File "/usr/bin/pungi", line 124, in main
    mypungi.doBuildinstall()
  File "/usr/lib/python2.7/site-packages/pypungi/__init__.py", line 845, in doBuildinstall
    workdir=workdir, outputdir=outputdir)
  File "/usr/lib/python2.7/site-packages/pylorax/__init__.py", line 404, in run
    i.backup_required(self.workdir)
  File "/usr/lib/python2.7/site-packages/pylorax/images.py", line 417, in backup_required
    self.reqs["splash"] = cpfile(splash, workdir)
  File "/usr/lib/python2.7/site-packages/pylorax/sysutils.py", line 133, in cpfile
    shutil.copy2(src, dst)
  File "/usr/lib64/python2.7/shutil.py", line 127, in copy2
    copyfile(src, dst)
  File "/usr/lib64/python2.7/shutil.py", line 81, in copyfile
    with open(src, 'rb') as fsrc:
IOError: [Errno 2] No such file or directory: '/work/Fedora/x86_64/yumroot/usr/share/anaconda/boot/syslinux-vesa-splash.jpg'

Some file names were changed from fedora-logos-16.0.1 to fedora-logos-16.0.2 and the hard coded paths in lorax no longer work.

Version-Release number of selected component (if applicable):
lorax-16.4.3-1.fc16

How reproducible:
Every time

Steps to Reproduce:
1. use pungi to build a boot.iso on a system with the latest lorax and fedora-logos
Comment 1 Tim Flink 2011-09-17 19:16:56 EDT
Created attachment 523730 [details]
patch to fix paths to line up with new fedora-logos

I patched lorax to work with the new fedora-logos. After building a new RPM with this patch locally, pungi completes with no issues.
Comment 2 Tim Flink 2011-09-17 19:18:54 EDT
Proposing as a blocker for Fedora 16 beta because it prevents the creation of install media.
Comment 3 Fedora Update System 2011-09-19 09:37:01 EDT
lorax-16.4.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lorax-16.4.4-1.fc16
Comment 4 Fedora Update System 2011-09-19 14:30:15 EDT
Package lorax-16.4.4-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-16.4.4-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/lorax-16.4.4-1.fc16
then log in and leave karma (feedback).
Comment 5 Tim Flink 2011-09-19 16:10:32 EDT
I created a new boot.iso with the new lorax and fedora-logos. The image was spun up successfully and has the new syslinux theme.
Comment 6 Adam Williamson 2011-09-21 21:04:08 EDT
Discussed at the 2011-09-21 go/no-go meeting (note: in #fedora-meeting-1),
acting as a blocker review meeting. Agreed to take this as a blocker as it can prevent image compose from working.
Comment 7 Fedora Update System 2011-09-25 21:40:44 EDT
lorax-16.4.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.