Bug 73935 - Does not work when installed with an umask of 077 and messes filesystem
Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mod_perl (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
David Lawrence
http://www.tu-chemnitz.de/~ensc/dirch...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 10:56 EDT by Enrico Scholz
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-06 12:53:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 10:56:05 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Bundle /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Bundle/ApacheTest.pm
| file /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Bundle is not owned by any package
| mod_perl-1.99_04-3


Version-Release number of selected component (if applicable):

mod_perl-1.99_04-3


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that mod_perl is uninstalled completely
   (rm -rf /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Bundle)
3. rpm -U mod_perl-1.99_04-3.i386.rpm
4. ls -l /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Bundle
5. use the programs/scripts/libraries of the package as non-root user
6. rpm -e mod_perl-1.99_04-3

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 16:19 /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Bundle
* files can not be found/read at 5 and
* /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Bundle still exists after 6.
Comment 1 Gary Benson 2002-09-13 12:12:40 EDT
The directories in question are intentionally not owned by mod_perl since other
packages put files in there.  The real solution to this is probably to make the
perl package create and own all auto and Bundle directories and to fix the other
packages that claim to own them (perl-DBI, perl-DBD-MySQL and perl-DBD-Pg).
Comment 2 Gary Benson 2002-09-13 12:18:55 EDT
I filed this as bug 73970.
Comment 3 Enrico Scholz 2002-09-13 12:21:17 EDT
rpm allows directories to be shared between several packages. The directory will
be kept when there are existing other packages owning it and removed when there
are no such packages.

Because there are too much perl-XXX bundle packages it makes no sense to let all
possible directories under /usr/lib/perl5 owned by perl or to create perl-XXX
hierarchie packages describing the perl-filesystem.

Jeff Johnson spends a lot of energy into rpm to add features like refcounted
directories, so you should these them ;)
Comment 4 Gary Benson 2002-09-13 12:32:37 EDT
It's not a question of making 'all possible directories under /usr/lib/perl5
owned by perl', merely a question of making perl own
/usr/lib/perl5/vendor_perl/$VER/$ARCH/{Bundle,auto} and
/usr/lib/perl5/vendor_perl/$VER/{Bundle,auto}.

Anyway I'll go with whatever Chip says on this...

Note You need to log in before you can comment on or make changes to this bug.