Bug 73936 - Boujou 2 crash with glibc
Boujou 2 crash with glibc
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 11:03 EDT by Knut J BJuland
Modified: 2016-11-24 09:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 17:59:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2002-09-13 11:03:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020830

Description of problem:
Boujou 2 segemfault when starting with limbo glibcs 0x4202cb30 in
__strtol_internal () from /lib/i686/libc.so.6

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.http://www.2d3.com/2d3/products/features.shtml, download Boujou 2 
2.ddd boujou2_demo 
3.
	

Actual Results:  GNU DDD 3.3.1 (i386-redhat-linux-gnu), by Dorothea L|tkehaus
and Andreas Zeller.
Copyright ) 1995-1999 Technische Universitdt Braunschweig, Germany.
Copyright ) 1999-2001 Universitdt Passau, Germany.
(no debugging symbols found)...(gdb) set args
(gdb) run
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...
Program received signal SIGSEGV, Segmentation fault.
0x4202cb30 in __strtol_internal () from /lib/i686/libc.so.6
(gdb) 

Expected Results:  program should start

Additional info:
Comment 1 Jakub Jelinek 2002-09-20 05:23:02 EDT
That's most likely because the program calls strtol with bogus arguments.

Note You need to log in before you can comment on or make changes to this bug.