Bug 739369 - Upgrading FC14 to FC15 leaves no acpid, smartd, hwclock, readahead, cron running after reboot
Summary: Upgrading FC14 to FC15 leaves no acpid, smartd, hwclock, readahead, cron runn...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 15
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-18 09:49 UTC by Ian Donaldson
Modified: 2011-09-21 22:49 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-21 17:59:37 UTC


Attachments (Terms of Use)

Description Ian Donaldson 2011-09-18 09:49:50 UTC
Description of problem:

Using yum update distro-sync from FC14 to FC15 doesn't leave
you with acpid, smartd, hwclock, readahead services enabled.

(and cron too, see https://bugzilla.redhat.com/show_bug.cgi?id=735802)


Version-Release number of selected component (if applicable):

systemd-26-9.fc15.i686



How reproducible:

100%

Steps to Reproduce:
1.yum --releasever=15 --disableplugin=presto distro-sync
2.yum groupinstall Base
3.grub-install /dev/whatever
4.sync; sync; reboot -f
  
Actual results:

ls -l /.readahead    - file doesn't exist
ps -ef|grep acpid    - not running
ps -ef|grep smartd   - not running, despite enabled in /etc/rc*.d


Expected results:

If running before the upgrade they should be running after 


Additional info:

These workaround the problem:

 ---
mkdir -p /etc/systemd/system/default.target.wants
ln -s /lib/systemd/system/systemd-readahead-collect.service /etc/systemd/system/default.target.wants/systemd-readahead-collect.service
ln -s /lib/systemd/system/systemd-readahead-replay.service /etc/systemd/system/default.target.wants/systemd-readahead-replay.service

mkdir -p /etc/systemd/system/sysinit.target.wants
ln -s /lib/systemd/system/hwclock-load.service /etc/systemd/system/sysinit.target.wants/hwclock-load.service

ln -s /lib/systemd/system/acpid.service /etc/systemd/system/multi-user.target.wants/acpid.service

ln -s /lib/systemd/system/smartd.service /etc/systemd/system/multi-user.target.wants/smartd.service

 ---

See https://bugzilla.redhat.com/show_bug.cgi?id=735802 for the cron workaround.

I suspect these (and the cron workaround) should be mentioned
in the distro-sync to FC15 section of the upgrade notes as they
will affect every upgrade.

There may be other services similary affected; these are just the ones
I've spotted in my travels so far.

Comment 1 Bill Nottingham 2011-09-19 19:14:32 UTC
This is a bug in the scripts for the converted services - please file against them.

Comment 2 Lennart Poettering 2011-09-21 17:59:37 UTC
hwclock is unnecessary since PID 1 calls the one necessary ioctl anyway.

readahead got obsoleted by systemd's readahead implementation.

For the others please file individual bugs against those packages.

Comment 3 Ian Donaldson 2011-09-21 22:49:53 UTC
I got the hwclock, readahead etc links from a freshly installed FC15 system;
they were missing on my distro-sync upgraded one.

The readahead link is for the new systemd based readahead implementation.


Note You need to log in before you can comment on or make changes to this bug.