Bug 739379 - openmpi, mpich2, octave and libraries path
Summary: openmpi, mpich2, octave and libraries path
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: octave
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-18 11:58 UTC by Hikari
Modified: 2011-09-18 14:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-18 14:12:19 UTC


Attachments (Terms of Use)

Description Hikari 2011-09-18 11:58:59 UTC
Octave fails to start: 

octave: error while loading shared libraries: libmpi.so.0: cannot open shared object file: No such file or directory

---
Description of problem:

Open MPI libraries point to /usr/lib64/openmpi/
Open MPI libraries point to /usr/lib64/mpich2/

But octave is unable to find then unless they are under /usr/lib64/

1) These two should conflict to each other
2) They need to be linked

---
Workaround A:
ln -s /usr/lib64/openmpi/lib/libmpi.so.0 /usr/lib64/

Fix:
ldconfig -l /usr/lib64/openmpi/* 
ldconfig -l /usr/lib64/mpich2/* 

and make the rpm to conflict with one another.

--- 
Versions:
octave-3.4.2-2.el6.x86_64
hdf5-openmpi-1.8.5.patch1-5.el6.x86_64
hdf5-openmpi-1.8.5.patch1-5.el6.x86_64

Comment 1 Susi Lehtola 2011-09-18 14:09:42 UTC
This is by design. We can't have different libraries with the same name, it would lead to strange results.

Besides, even if you load the libraries, you probably won't be able to use MPI. Seems like octave is somehow linked to the wrong version of hdf5.

Comment 2 Susi Lehtola 2011-09-18 14:12:19 UTC
I can't reproduce this.

$ rpm -q hdf5-openmpi octave
hdf5-openmpi-1.8.5.patch1-5.el6.x86_64
octave-3.4.2-2.el6.x86_64

$ octave
GNU Octave, version 3.4.2
Copyright (C) 2011 John W. Eaton and others.
This is free software; see the source code for copying conditions.
There is ABSOLUTELY NO WARRANTY; not even for MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE.  For details, type `warranty'.
(clip)

You must have messed up your environment somehow.


Note You need to log in before you can comment on or make changes to this bug.