Bug 739388 - VDSM: migrating vm with rhevm-tools attached will fail when iso domain is detached from data center
Summary: VDSM: migrating vm with rhevm-tools attached will fail when iso domain is det...
Keywords:
Status: CLOSED DUPLICATE of bug 725673
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.2
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Dan Kenigsberg
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-18 14:05 UTC by Dafna Ron
Modified: 2016-04-18 06:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-18 15:59:35 UTC


Attachments (Terms of Use)
logs (688.25 KB, application/x-gzip)
2011-09-18 14:05 UTC, Dafna Ron
no flags Details

Description Dafna Ron 2011-09-18 14:05:06 UTC
Created attachment 523751 [details]
logs

Description of problem:

while I had ISO domain attached to my Data Center, I ran a VM. 
The rhevm-tools cd is attached automatically to the VM if tools are not already installed and if you have an ISO domain attached. 
While the VM was up I detached the ISO domain and tried to migrate the vm. 
migration failes with error: 

libvirtError: internal error process exited while connecting to monitor: qemu-kvm: -drive file=/rhev/data-center/85f41813-ab57-419c-b05c-f4ccb9f8fa27/771adde0-5939-4543-bdc6-0b1
baee0676b/images/11111111-1111-1111-1111-111111111111/RHEV-toolsSetup_3.0_17.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw: could not open disk image /rhev/da
ta-center/85f41813-ab57-419c-b05c-f4ccb9f8fa27/771adde0-5939-4543-bdc6-0b1baee0676b/images/11111111-1111-1111-1111-111111111111/RHEV-toolsSetup_3.0_17.iso: No such file or direc
tory


Version-Release number of selected component (if applicable):

ic140.2
vdsm-4.9-100.el6.x86_64
libvirt-0.9.4-0rc1.2.el6.x86_64

How reproducible:

100%

Steps to Reproduce:
1. run a vm with windows OS while iso domain with rhevm-tools is attached
2. detach iso domain
3. tryt o manually migrate the vm
  
Actual results:

migration will fail 

libvirtError: internal error process exited while connecting to monitor: qemu-kvm: -drive file=/rhev/data-center/85f41813-ab57-419c-b05c-f4ccb9f8fa27/771adde0-5939-4543-bdc6-0b1
baee0676b/images/11111111-1111-1111-1111-111111111111/RHEV-toolsSetup_3.0_17.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw: could not open disk image /rhev/da
ta-center/85f41813-ab57-419c-b05c-f4ccb9f8fa27/771adde0-5939-4543-bdc6-0b1baee0676b/images/11111111-1111-1111-1111-111111111111/RHEV-toolsSetup_3.0_17.iso: No such file or direc
tory


Expected results:

migration should not fail. 

Additional info: logs attached

Thread-1218::ERROR::2011-09-18 16:37:16,777::vm::175::vm.Vm::(_recover) vmId=`9981d67b-e9f8-4a91-840d-48d9779cf351`::internal error process exited while connecting to monitor: q
emu-kvm: -drive file=/rhev/data-center/85f41813-ab57-419c-b05c-f4ccb9f8fa27/771adde0-5939-4543-bdc6-0b1baee0676b/images/11111111-1111-1111-1111-111111111111/RHEV-toolsSetup_3.0_
17.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw: could not open disk image /rhev/data-center/85f41813-ab57-419c-b05c-f4ccb9f8fa27/771adde0-5939-4543-bdc6-0b1
baee0676b/images/11111111-1111-1111-1111-111111111111/RHEV-toolsSetup_3.0_17.iso: No such file or directory

Dummy-71::DEBUG::2011-09-18 16:37:17,712::storage_mailbox::623::Storage.Misc.excCmd::(_checkForMail) 'dd if=/rhev/data-center/85f41813-ab57-419c-b05c-f4ccb9f8fa27/mastersd/dom_m
d/inbox iflag=direct,fullblock count=1 bs=1024000' (cwd None)
Dummy-71::DEBUG::2011-09-18 16:37:17,828::storage_mailbox::623::Storage.Misc.excCmd::(_checkForMail) SUCCESS: <err> = '1+0 records in\n1+0 records out\n1024000 bytes (1.0 MB) co
pied, 0.0493369 s, 20.8 MB/s\n'; <rc> = 0
Thread-1218::ERROR::2011-09-18 16:37:18,788::vm::230::vm.Vm::(run) vmId=`9981d67b-e9f8-4a91-840d-48d9779cf351`::Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 222, in run
    self._startUnderlyingMigration()
  File "/usr/share/vdsm/libvirtvm.py", line 305, in _startUnderlyingMigration
    libvirt.VIR_MIGRATE_PEER2PEER, None, maxBandwidth)
  File "/usr/share/vdsm/libvirtvm.py", line 327, in f
    ret = attr(*args, **kwargs)
  File "/usr/share/vdsm/libvirtconnection.py", line 63, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 886, in migrateToURI
    if ret == -1: raise libvirtError ('virDomainMigrateToURI() failed', dom=self)
libvirtError: internal error process exited while connecting to monitor: qemu-kvm: -drive file=/rhev/data-center/85f41813-ab57-419c-b05c-f4ccb9f8fa27/771adde0-5939-4543-bdc6-0b1
baee0676b/images/11111111-1111-1111-1111-111111111111/RHEV-toolsSetup_3.0_17.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw: could not open disk image /rhev/da
ta-center/85f41813-ab57-419c-b05c-f4ccb9f8fa27/771adde0-5939-4543-bdc6-0b1baee0676b/images/11111111-1111-1111-1111-111111111111/RHEV-toolsSetup_3.0_17.iso: No such file or direc
tory

Comment 2 Dan Kenigsberg 2011-09-18 15:59:35 UTC
Dafna, I am afraid this is a known issue. Unlike RHEV-2.2, 3.0 uses libvirt which fails migration if the destination cannot see the CD image (bug 725673). You would have to eject the CD before migration.

*** This bug has been marked as a duplicate of bug 725673 ***


Note You need to log in before you can comment on or make changes to this bug.