Bug 739428 - kickstart user doesn't work correctly
kickstart user doesn't work correctly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-09-18 21:59 EDT by Brian Lane
Modified: 2011-09-24 00:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: anaconda-16.19-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-24 00:36:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2011-09-18 21:59:26 EDT
The createUser function was modified to use kwargs instead of explicit arguments. It checks to see if various attributes are in the kwargs or not, using that logic to set the homedir to the user specified homedir or the default /home

The problem is that pykickstart sets all of these to defaults like "" and False. So the attributes will always be set. So createUser needs to check for values in addition to the attribute's existance in kwargs.

The work-around is to specify all of the various settings for the kickstart user command.
Comment 1 Fedora Update System 2011-09-23 17:48:50 EDT
anaconda-16.19-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.19-1.fc16
Comment 2 Fedora Update System 2011-09-24 00:35:30 EDT
anaconda-16.19-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.