Bug 739466 -   (possibly all global entities) breaks topics
Summary:   (possibly all global entities) breaks topics
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: PressGang CCMS
Classification: Community
Component: Web-UI
Version: 1.x
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Matthew Casperson
QA Contact: Misha H. Ali
URL:
Whiteboard:
Depends On:
Blocks: 825005
TreeView+ depends on / blocked
 
Reported: 2011-09-19 07:23 UTC by Misha H. Ali
Modified: 2014-08-04 22:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 825005 (view as bug list)
Environment:
Last Closed: 2011-10-18 09:01:15 UTC


Attachments (Terms of Use)

Description Misha H. Ali 2011-09-19 07:23:01 UTC
Description of problem:

Using the   entity to indicate a non breaking space, as follows:

Red Hat Enterprise Linux 6 (this allows no breaks between the name of the product and the version number)

The above usage causes a topic failed XML validation error (Example error below):

Topic 5158 failed xml validation.

Note: A topic which had   removed is still breaking. This may be due to other global entities (< and > are used in this topic) but it may be due to some other factor therefore the global entities is still not completely tested.

How reproducible:

100%

Steps to Reproduce:
1. Create a topic.
2. Enter a product name then   and product version between para tags.
3. Brew.
  
Actual results:

Topic xxxx failed xml validation. 

Expected results:

Successful brew to stage.

Comment 1 Stephen Gordon 2011-09-21 22:14:39 UTC
This issue also affects the CLI tool, as seen in Bug # 734986.

Comment 2 Matthew Casperson 2011-10-11 00:41:17 UTC
Fixed in 20111011-1034

See http://sourceforge.net/p/commonclasses/code/14/tree/trunk/src/com/redhat/ecs/commonutils/XMLUtilities.java convertStringToDocument() for details.


Note You need to log in before you can comment on or make changes to this bug.