Bug 739470 - win7 32bit guest stuck on reboot/poweroff with -smp 1
Summary: win7 32bit guest stuck on reboot/poweroff with -smp 1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 721355
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 07:44 UTC by Mike Cao
Modified: 2013-01-10 00:21 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 721355
Environment:
Last Closed: 2011-09-19 10:53:14 UTC


Attachments (Terms of Use)

Description Mike Cao 2011-09-19 07:44:34 UTC
Description of problem:
 And either shutting down guest trough start->shutdown or shutting down guest gracefully from admin/user portal leads to following state:

seems like there is no explorer running and I can see only a default blue wallpaper. Guest is not responding on signals like ctrl+alt+delete.

In case of Win7x32 there is only Shutting down screen and nothing happens.


Version-Release number of selected component (if applicable):

winxp/win7x32 guest with ic129 RHEV-Agent.msi installed

qemu-kvm-0.12.1.2-2.190.el6.x86_64




How reproducible:
100%

Steps to Reproduce:
1. start win7_32 bit guest with -smp=1
CLI:/usr/libexec/qemu-kvm -M rhel6.2.0 -usb -device usb-tablet -cpu cpu64-rhel6,+x2apic -enable-kvm -m 2048 -smp 1 -name win7_32 -uuid 9c1e21b1-1740-4117-8328-c8ae7c94068b -monitor unix:/tmp/tt,server,nowait -rtc base=localtime -boot c -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x4 -drive file=/home/backup/test/win7_32,if=none,id=drive-virtio-disk0,format=raw,serial=83-befe-af9a2dbb0177,cache=none,werror=stop,rerror=stop,aio=threads -device ide-drive,drive=drive-virtio-disk0,id=virtio-disk0 -netdev tap,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:1a:4a:42:0b:01,bus=pci.0,addr=0x3 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/win7_64.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0 -usb -vnc :10 -k en-us -vga cirrus
2.disable UAC in the guest
3.install virtio serial driver from virtio-win-prewhql-0.16 (\\WXp\x86\vioser.inf)
4.install RHEV-Agent.msi from ic129
5.make sure rhev-agents must be started in windows services
6.reboot guest

  
Actual results:
guest will stuck during reboot


Expected results:
reboot successfully

Additional info:
1.tried smp=2 smp=4 ,can *not* reproduce this issue
2.Tried stop rhev-agent service before reboot/poweroff guest ,can *not* reboot this issue
3.tried windows update ,still hit this issue .
4,dmp file referring to https://bugzilla.redhat.com/attachment.cgi?id=522091
5.windbg debug info (!process 0 7) referring to https://bugzilla.redhat.com/attachment.cgi?id=522090

Comment 1 Mike Cao 2011-09-19 10:53:14 UTC
This one should be a known issue for RHEV-agents .After I update rhev-agents.msi from  rhev-guest-tools-iso-3.0-21 .the issue has gone 

Closing


Note You need to log in before you can comment on or make changes to this bug.