Bug 739472 - tab-completion of $FOO/ becomes \$FOO/
Summary: tab-completion of $FOO/ becomes \$FOO/
Keywords:
Status: CLOSED DUPLICATE of bug 679696
Alias: None
Product: Fedora
Classification: Fedora
Component: bash
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Roman Rakus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 07:55 UTC by Jonathan Wakely
Modified: 2014-01-13 00:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 11:15:16 UTC


Attachments (Terms of Use)

Description Jonathan Wakely 2011-09-19 07:55:25 UTC
Description of problem:

tab-completion of a path containing a shell variable insets a backslash to escape the $ in the variable

Version-Release number of selected component (if applicable):

bash-4.2.10-4.fc15.x86_64
bash-completion-1.3-5.fc15.noarch

How reproducible:

Always

Steps to Reproduce:
1.  ls $PWD/.<TAB><Enter>
2.  ls $HOME/.<TAB><Enter>

  
Actual results:

bash-completion inserts a backslash before the $, causing the commands to fail

ls: cannot access $PWD/.: No such file or directory
ls: cannot access $HOME/.: No such file or directory


Expected results:

no backslash, commands work

Additional info:

uninstalling bash-completion didn't help, so I've used Component=bash

Comment 1 Roman Rakus 2011-09-19 11:15:16 UTC

*** This bug has been marked as a duplicate of bug 679696 ***


Note You need to log in before you can comment on or make changes to this bug.