Bug 739486 - After "virsh snapshot-revert", the change made between two snapshot is still there
Summary: After "virsh snapshot-revert", the change made between two snapshot is still ...
Keywords:
Status: CLOSED DUPLICATE of bug 733762
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: 6.2
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 08:52 UTC by Gunannan Ren
Modified: 2014-06-18 07:18 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 14:48:35 UTC


Attachments (Terms of Use)

Description Gunannan Ren 2011-09-19 08:52:41 UTC
Description of problem:
After doing the virsh snapshot-revert offline, the changed made recently is still
there, whereas the command return success. For online snapshot, no such problem.
and on libvirt-0.9.4-11.el6, the bug have been fixed.

Version-Release number of selected component (if applicable):
libvirt-0.9.4-7.2.el6


How reproducible:

always

Steps to Reproduce:
1.virsh snapshot-create <guest> snapshot1
2.touch a file in the guest OS 
3.virsh snapshot-revert <guest> snapshot1
4.the file still there
  
Actual results:
change is still there

Expected results:
revert as expected

Additional info:

Comment 1 Eric Blake 2011-09-19 14:48:35 UTC
Libvirt 0.9.4-7.2 intentionally does not contain any snapshot fixes.  This is a known upstream problem, and was fixed for libvirt 0.9.4-8 by bug 733762#c2.  I'm closing this as a duplicate.

*** This bug has been marked as a duplicate of bug 733762 ***


Note You need to log in before you can comment on or make changes to this bug.