Bug 739493 - qemu-kvm should promote friendly hint/message rather than core dump when pci address beyond 32
Summary: qemu-kvm should promote friendly hint/message rather than core dump when pci ...
Keywords:
Status: CLOSED DUPLICATE of bug 678729
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Don Dutile
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 09:26 UTC by FuXiangChun
Modified: 2013-01-10 00:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-27 21:16:26 UTC


Attachments (Terms of Use)

Description FuXiangChun 2011-09-19 09:26:38 UTC
Description of problem:
for example: boot guest with addr=0x21.0, it will lead to qemu core dump. if addr values <0x20 then guest work well 

Version-Release number of selected component (if applicable):
# uname -r
2.6.32-191.el6.x86_64
# rpm -qa|grep kvm
qemu-kvm-0.12.1.2-2.190.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1./usr/libexec/qemu-kvm -m 4G -smp 4 -drive file=/dev/vg0/data512,if=none,id=drive-virtio0-0-0,format=qcow2,werror=ignore,rerror=ignore,cache=none -device virtio-blk-pci,drive=drive-virtio0-0-0,id=virti0-0-0 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:56:00:94:a3:f8,bootindex=1 -uuid 9e6f04cf-2ad7-45aa-9333-2d2ee26570c6 -boot c -monitor stdio -spice id=on,disable-ticketing,port=5911 -drive file=/dev/vg0/data126,if=none,id=drive-virtio0-0-126,format=qcow2,cache=none -device virtio-blk-pci,drive=drive-virtio0-0-126,id=virti0-0-126,addr=0x21.0
2.
3.
  
Actual results:
core dump

Expected results:
Should have a hint or restrictions,should not core dump directly.

Additional info:

Comment 2 Don Dutile 2011-09-27 21:16:26 UTC
Closing since patch posted to resolve this problem for bz 678729.

*** This bug has been marked as a duplicate of bug 678729 ***


Note You need to log in before you can comment on or make changes to this bug.