Bug 739499 - kernel-3.1.0-0.rc6.git0.3.fc16.x86_64 won't boot on EC2
Summary: kernel-3.1.0-0.rc6.git0.3.fc16.x86_64 won't boot on EC2
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 09:58 UTC by Marek Goldmann
Modified: 2012-02-14 15:56 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-14 15:56:22 UTC


Attachments (Terms of Use)
EC2 boot log (23.41 KB, text/plain)
2011-09-19 10:03 UTC, Marek Goldmann
no flags Details

Description Marek Goldmann 2011-09-19 09:58:26 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Marek Goldmann 2011-09-19 10:02:22 UTC
Uh, premature click on add attachment button, sorry.

Description of problem:

Newest kernel from updates-testing won't boot on Amazon EC2. I'll attach console log.

Version-Release number of selected component (if applicable):

kernel-3.1.0-0.rc6.git0.3.fc16.x86_64

How reproducible:

Sometimes - it boots successfully on some hosts on EC2, on some not. IIRC I've seen this with previous kernel versions too, but I'm not sure now if this was the exact same issue.

Comment 2 Marek Goldmann 2011-09-19 10:03:02 UTC
Created attachment 523815 [details]
EC2 boot log

Comment 3 Chuck Ebbert 2011-09-19 13:49:21 UTC
Your guest is trying to use the "mwait" instruction, which cannot be used in a guest. This could be due to misconfiguration or a bug in the EC2 host code, which should be masking this instruction from the CPU feature list so guests cannot use it.

One workaround would be to add "intel_idle.max_cstate=0" to the kernel options. You may also have to add "nomwait" as well.

Comment 4 Chuck Ebbert 2011-09-19 14:22:43 UTC
On second thought, it looks like only "nomwait" should be needed.

Comment 5 Chuck Ebbert 2011-09-20 11:10:28 UTC
That's "idle=nomwait".

Comment 6 Dennis Gilmore 2011-09-21 15:36:41 UTC
idle=nomwait has worked for me.

Comment 7 Chuck Ebbert 2011-09-26 13:07:02 UTC
Looks like there are still some problems with "idle=nomwait". If that doesn't work use "idle=halt".

Comment 8 Josh Boyer 2011-11-09 18:31:00 UTC
Konrad, will patch 1/3 in this series help this issue?

http://thread.gmane.org/gmane.comp.emulators.xen.devel/115063/focus=1212837

Comment 9 Konrad Rzeszutek Wilk 2011-11-10 04:08:16 UTC
Hey Josh,

That patch series definitely fixes more than one distro issue :-)

And yes, that patch should do it. In the meantime the workaround that Chuck suggested is proper.

I guess this BZ can be marked as POST?

Comment 10 Josh Boyer 2011-11-10 12:31:04 UTC
Thanks!

Comment 11 Konrad Rzeszutek Wilk 2012-02-10 14:36:00 UTC
So patch is upstream. I think this can be closed?

Comment 12 Josh Boyer 2012-02-10 15:15:00 UTC
(In reply to comment #11)
> So patch is upstream. I think this can be closed?

Which commit(s)?  I don't see anything that look like the patches in the gmane thread in comment #8 in Linus' tree as of this morning.

Comment 13 Konrad Rzeszutek Wilk 2012-02-14 15:42:37 UTC
e5fd47bfab2df0c2184cc0bf4245d8e1bb7724fb

Comment 14 Josh Boyer 2012-02-14 15:56:22 UTC
(In reply to comment #13)
> e5fd47bfab2df0c2184cc0bf4245d8e1bb7724fb

Indeed.  I guess I didn't look back far enough.  Thank you Konrad


Note You need to log in before you can comment on or make changes to this bug.