Bug 739544 - Gnome fails to load and crashes when the Evolution-exchange plugin is configured.
Summary: Gnome fails to load and crashes when the Evolution-exchange plugin is configu...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: folks
Version: 16
Hardware: i686
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 13:15 UTC by Tom Mannerhagen
Modified: 2011-09-21 15:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-21 15:13:22 UTC


Attachments (Terms of Use)
Picture of abrt contents (1.03 MB, image/jpeg)
2011-09-21 06:21 UTC, Tom Mannerhagen
no flags Details
ABRT content from last failed login attempt. (5.10 MB, application/x-gzip)
2011-09-21 08:45 UTC, Tom Mannerhagen
no flags Details
backtrace generated from the above report (31.24 KB, text/plain)
2011-09-21 14:40 UTC, Milan Crha
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 659732 None None None Never

Description Tom Mannerhagen 2011-09-19 13:15:40 UTC
Description of problem:
After having installed and configured the Evolution-exchange plugin, Evolution crashes and subsequent login attempts to the Gnome desktop fails with this sad face and a Log out button. 

Version-Release number of selected component (if applicable):
Currently the package has version 3.1.91-1.fc16(i686)

How reproducible:
100% of the subsequent logins fails.
The only way to login is to create a new user from Root terminal, delete the old user including files, re-create the user and then log in.

Steps to Reproduce:
1. Install the Evolution-exchange-3.1.91-1.fc16(i686) plugin
2. Set up an OWA account in Evolution (previously account may, but need not be set up)
3. After finishing the setup of the plugin/Evolution, Evolution crashes and finally the Gnome session ends with a sad face.
  
Actual results:
Gnome session failed. Log out the only possibility.

Expected results:
Having access to OWA in Evolution.


Additional info:
If I am not thrown out of Gnome at once, I can see that my OWA mails are properly populated in Evolution. So the connector itself seems to work,

Comment 1 Milan Crha 2011-09-19 13:50:07 UTC
Thanks for a bug report. Could you provide a backtrace of the crash, with debug info packages, installed, please? If it's in evolution, then debug info packages for gtkhtml3, evolution-data-server, evolution and evolution-exchange would be enough. I'm wondering whether this has anything to do with glib2 rebuilds of evolution-data-server and evolution, which had been done just after 3.1.91 release. I'm also working on an update to 3.1.92 right now, it may reach updates-testing in a day, approximately.

Comment 2 Tom Mannerhagen 2011-09-19 19:22:54 UTC
Hi

I would like to do so - if I knew how.
I mean - I may be able to install the packages You suggest, but how can I get anything from my users profile since Gnome throws me out so fast?

Let me know how to help and remember - I am not a developer. :)

BR

Tom

Comment 3 Matthew Barnes 2011-09-19 20:05:39 UTC
First try uninstalling evolution-exchange and see if you can log in again.

Comment 4 Tom Mannerhagen 2011-09-20 06:44:44 UTC
Hi

Thanks for the hint! I should have thought of this myself :)
But even after uninstalling the evolution-exchange package I am thrown out from Gnome.
Should I maybe try uninstalling Evolution or does this not make any sense?

Cheers

Comment 5 Milan Crha 2011-09-20 07:12:36 UTC
There is only one process from evolution which is run on a session start, it's the evolution-alarm-notify process, which is run due to
   /etc/xdg/autostart/evolution-alarm-notify.desktop
thus removing it may stop running it on session start. If anything else is using the evolution-data-server factories then it's another thing.

When you check /var/spool/abrt/ before the login and after, does it contain any new directories? The executable file in a subfolder should tell you what application crashed, I suppose (I do not know abrt much).

I filled a 3.1.92 update yesterday, please try to update from it, it's in updates-testing (edit the /etc/yum.repos.d/fedora-updates-testing.repo and set enabled=1 in the first section, then run yum update evolution; it should update everything evolution-related). The only question is whether this is due to evolution or not.

Comment 6 Tom Mannerhagen 2011-09-20 08:15:18 UTC
Ok

So I can find that abrt/ is filled up with 2 directories after a failed Gnome session.
One directory holds a file called executable with the content "/usr/bin/gsettings-data-convert"

Would You need the full contents from this directory?
I probably can compress the files and add to this bug.

Tom

Comment 7 Matthew Barnes 2011-09-20 12:49:23 UTC
It sounds to me like your desktop login issues may not be related to Evolution, especially considering that Evolution doesn't use GSettings yet.

Comment 8 Tom Mannerhagen 2011-09-20 13:05:36 UTC
Ok

You may be right - but the issue always appears after having configured evolution-exchange plugin.
So no other changes are done to the system at all.

I have done the test a few times and the procedure is like this:

I have 2 user accounts. 1 from which I can "rescue" my main account.
The main account works fine until I have set up Evolution-exchange. When that setup is finished, Gnome crashes and I am given the sad face and the Logout-screen.
Any subsequent login-attempt with my main profile is unsuccessful with the same symptom as described above.
If I remove my main account including all files, create it again, I can log in as normal. This works fine until the named plugin is configured again.

Normally I have 3 different mail-accounts in Evolution.
Setting up 1 or 2 non-exchange accounts works perfect. Regardless of order or number of accounts. 

Hope this provides anymore info.

Comment 9 Tom Mannerhagen 2011-09-21 06:20:56 UTC
Hi again

Checked the abrt directory this morning after having cleared it and made an unsuccessful login attempt into Gnome.
It contains 2 directories with a few seconds in between.
The first executable is what I have reported before - gsettings-data-convert
The second directory, created some seconds later has the executable gnome-shell.

Uploading a picture of the directories and the contents of the files if this helps You.

Comment 10 Tom Mannerhagen 2011-09-21 06:21:53 UTC
Created attachment 524137 [details]
Picture of abrt contents

Comment 11 Tom Mannerhagen 2011-09-21 07:27:18 UTC
And I forgot to mention that I am currently using evolution-exchange 3.1.92 from updates-testing.

Cheers!

Comment 12 Milan Crha 2011-09-21 08:18:53 UTC
Thanks for the update. I currently tried to reproduce this, with the same evolution-exchange version, though for me it's not with gnome-shell, but with a fallback mode. I saw an issue with the notification applet, something about unexpected exit of it, but apart of that nothing, furthermore, I wasn't able to reproduce this applet exit whatever I tried.

Please try to get backtrace from the abrt crash report for the gnome-shell, as it's the application which is showing you the "sad face" with the logout prompt.

Comment 13 Tom Mannerhagen 2011-09-21 08:43:01 UTC
Hi

Here is what I found.
I hope it is what You are looking for.

Comment 14 Tom Mannerhagen 2011-09-21 08:45:24 UTC
Created attachment 524159 [details]
ABRT content from last failed login attempt.

ABRT content from last failed login attempt.

Comment 15 Milan Crha 2011-09-21 14:40:49 UTC
Created attachment 524209 [details]
backtrace generated from the above report

Comment 16 Milan Crha 2011-09-21 14:43:56 UTC
And this is the crashing thread:
Thread 1 (Thread 0xb775c880 (LWP 2007)):
#0  g_str_hash (v=0x0) at gstring.c:142
#1  0x4cf6ac98 in gee_hash_map_lookup_node (self=0x9b44ed0, key=0x0) at hashmap.c:930
#2  0x4cf6aff1 in gee_hash_map_real_has_key (base=0x9b44ed0, key=0x0) at hashmap.c:969
#3  0x4cf5d578 in gee_abstract_map_has_key (self=0x9b44ed0, key=0x0) at abstractmap.c:313
#4  0x00909624 in _folks_backends_eds_backend_ab_source_list_changed_cb (self=0x954a570, list=<optimized out>) at /opt/gnome2/source/folks/backends/eds/eds-backend.vala:180
#5  0x49c70be4 in g_cclosure_marshal_VOID__VOID (closure=0x9bddf70, return_value=0x0, n_param_values=1, param_values=0x9be0600, invocation_hint=0xbfdc1120, marshal_data=0x0) at gmarshal.c:85
#6  0x49c6f6a5 in g_closure_invoke (closure=0x9bddf70, return_value=0x0, n_param_values=1, param_values=0x9be0600, invocation_hint=0xbfdc1120) at gclosure.c:774
#7  0x49c83bb0 in signal_emit_unlocked_R (node=0x955d468, detail=0, instance=0x9bcdf00, emission_return=0x0, instance_and_params=0x9be0600) at gsignal.c:3272
#8  0x49c8c85f in g_signal_emit_valist (instance=0x9bcdf00, signal_id=409, detail=0, var_args=0xbfdc12cc "p\016\v\n") at gsignal.c:3003
#9  0x49c8c9d4 in g_signal_emit (instance=0x9bcdf00, signal_id=409, detail=0) at gsignal.c:3060
#10 0x002d702a in load_from_gconf (list=0x9bcdf00) at e-source-list.c:172
#11 0x002d732f in conf_changed_callback (client=0x956f4b8, connection_id=3741319176, entry=0xaf115478, list=0x9bcdf00) at e-source-list.c:234
#12 0x4b15c008 in notify_listeners_callback (listeners=0x961f1d0, key=0xa19b558 "/apps/evolution/addressbook/sources", cnxn_id=3741319176, listener_data=0x9aa2498, user_data=0xbfdc13e8) at gconf-client.c:2810
#13 0x4b151d9f in notify_listener_list (listeners=0x961f1d0, user_data=0xbfdc13e8, callback=0x4b15bf50 <notify_listeners_callback>, key=0xa19b558 "/apps/evolution/addressbook/sources", list=0x9cbcc10) at gconf-listeners.c:590
#14 ltable_notify (user_data=0xbfdc13e8, callback=0x4b15bf50 <notify_listeners_callback>, key=0xa19b558 "/apps/evolution/addressbook/sources", lt=0x961f1d0) at gconf-listeners.c:656
#15 gconf_listeners_notify (listeners=0x961f1d0, all_above=0xa19b558 "/apps/evolution/addressbook/sources", callback=0x4b15bf50 <notify_listeners_callback>, user_data=0xbfdc13e8) at gconf-listeners.c:185
#16 0x4b15f7e8 in notify_one_entry (client=0x956f4b8, entry=0xaf115478) at gconf-client.c:2835
#17 0x4b15f8c7 in gconf_client_flush_notifies (client=0x956f4b8) at gconf-client.c:2875
#18 notify_idle_callback (data=0x956f4b8) at gconf-client.c:2769
#19 0x49b58401 in g_idle_dispatch (source=0x9f9edc8, callback=0x4b15f820 <notify_idle_callback>, user_data=0x956f4b8) at gmain.c:4801
#20 0x49b5c5bf in g_main_dispatch (context=0x9147330) at gmain.c:2441
#21 g_main_context_dispatch (context=0x9147330) at gmain.c:3011
#22 0x49b5cd00 in g_main_context_iterate (context=0x9147330, block=1236711392, dispatch=1, self=0x913c080) at gmain.c:3089
#23 0x49b5d337 in g_main_loop_run (loop=0x91497f0) at gmain.c:3297
#24 0x4aef33d0 in meta_run () at core/main.c:555
#25 0x0804a2b8 in main (argc=1, argv=0xbfdc1704) at main.c:571

Comment 17 Milan Crha 2011-09-21 14:45:16 UTC
I'm assigning this to folks, because the crash comes from there.

Comment 18 Milan Crha 2011-09-21 15:06:48 UTC
As a workaround, please move away /usr/lib/folks/27/backends/eds folder somewhere else, thus the eds backend will not run, and the gnome-shell will not crash.

Comment 19 Milan Crha 2011-09-21 15:13:22 UTC
I moved this upstream [1] and the fix will be probably included in the next release of folks. Please see [1] for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=659732


Note You need to log in before you can comment on or make changes to this bug.