Bug 739559 - cumin allows creating queue with special characters
Summary: cumin allows creating queue with special characters
Keywords:
Status: CLOSED DUPLICATE of bug 438142
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: 2.1.6
: ---
Assignee: Ernie
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks: 885729
TreeView+ depends on / blocked
 
Reported: 2011-09-19 13:40 UTC by Stanislav Graf
Modified: 2013-01-04 15:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 885729 (view as bug list)
Environment:
Last Closed: 2012-03-16 19:37:12 UTC


Attachments (Terms of Use)

Description Stanislav Graf 2011-09-19 13:40:43 UTC
Description of problem:
If queue '8786%^*&^*&^*&^' is added through cumin - Messaging - (broker name) - Add queue - '8786%^*&^*&^*&^'
This queue is properly displayed through qpid-config:
[root@rhel6i ~ ]$ qpid-config queues '8786%^*&^*&^*&^'
Queue Name       Attributes
========================================
8786%^*&^*&^*&^  --durable --file-size=24 --file-count=8 --argument qpid.optimistic_consume=False
(ecode=0)

But through cumin - Messaging - (broker name) we get following error:
XML Parsing Error: not well-formed
Location: http://server_name:45672/index.html?frame=main.messaging.broker;main.m=messaging;main.messaging.m=broker;main.messaging.broker.m=view;main.messaging.broker.id=1
Line Number 136, Column 477:      <tbody><tr><td class="id"><input type="checkbox" name="main.messaging.broker.view.body.queues.table.selection" value="32" tabindex="100"   onclick="cumin.clickTableCheckbox(this, 'main.messaging.broker.view.body.queues.table.selection')"/></td><td class="name selected"><a href="index.html?frame=main.messaging.broker.queue;main.m=messaging;main.messaging.m=broker;main.messaging.broker.id=1;main.messaging.broker.queue.m=view;main.messaging.broker.queue.id=32">8786%^*&^*&^*&^</a></td><td class="consumerCount">0</td><td class="bindingCount">1</td><td class="msgDepth">0</td><td class="byteDepth">0</td></tr><tr><td class="id"><input type="checkbox" name="main.messaging.broker.view.body.queues.table.selection" value="1" tabindex="100"   onclick="cumin.clickTableCheckbox(this, 'main.messaging.broker.view.body.queues.table.selection')"/></td>
...sniped...


Version-Release number of selected component (if applicable):
cumin-0.1.4916-1.el6
cumin-0.1.4916-1.el5

How reproducible:
100%

Steps to Reproduce:
1. cumin - Messaging - (broker name) - Add queue - '8786%^*&^*&^*&^'
2. qpid-config queues '8786%^*&^*&^*&^'
3. cumin - Messaging - (broker name)
  
Actual results:
cumin allows creating queue with special characters

Expected results:
cumin should check queue parameters and doesn't allow creating queue with special characters

Additional info:

Comment 1 Trevor McKay 2012-03-16 19:37:12 UTC
Application of xml escaping on queue names as part of Bug 438142 solves this issue.

*** This bug has been marked as a duplicate of bug 438142 ***


Note You need to log in before you can comment on or make changes to this bug.