Bug 739560 - /dev/stderr: No such device or address
Summary: /dev/stderr: No such device or address
Keywords:
Status: CLOSED DUPLICATE of bug 735618
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 13:49 UTC by Tom London
Modified: 2014-03-17 03:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 20:05:15 UTC


Attachments (Terms of Use)

Description Tom London 2011-09-19 13:49:47 UTC
Description of problem:
I'm seeing the following on fresh boots:

[root@tlondon ~]# dmesg | grep stderr
[   16.928522] fedora-readonly[440]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address
[   17.659543] fedora-storage-init[491]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address
[   22.220213] fedora-storage-init[834]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address
[   23.909572] sshd-keygen[870]: /etc/rc.d/init.d/functions: line 58: /dev/stderr: No such device or address
[root@tlondon ~]# 

[root@tlondon init.d]# ls -l /dev/stderr
lrwxrwxrwx. 1 root root 15 Sep 19 06:16 /dev/stderr -> /proc/self/fd/2
[root@tlondon init.d]# ls -lZ /dev/stderr
lrwxrwxrwx. root root system_u:object_r:device_t:s0    /dev/stderr -> /proc/self/fd/2
[root@tlondon init.d]# 

Appears to have started around 10 September:

/var/log/messages-20110911:Sep 10 18:11:22 tlondon NetworkManager[891]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address
/var/log/messages-20110911:Sep 10 18:11:26 tlondon NetworkManager[891]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address
/var/log/messages-20110911:Sep 10 18:11:27 tlondon dbus-daemon[946]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address

Not sure its relevant, but checking, I did update glibc roughtly near then:

glibc-2.14.90-8.x86_64


Version-Release number of selected component (if applicable):
initscripts-legacy-9.32-1.fc17.x86_64

How reproducible:
Every boot

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2011-09-19 13:54:57 UTC
Same messages after updating to glibc-2.14.90-9.x86_64:

[root@tlondon ~]# dmesg | grep stderr
[   16.226299] fedora-readonly[444]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address
[   21.750881] fedora-storage-init[824]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address
[   23.059568] fedora-storage-init[846]: /etc/init.d/functions: line 58: /dev/stderr: No such device or address
[   24.289909] sshd-keygen[869]: /etc/rc.d/init.d/functions: line 58: /dev/stderr: No such device or address
[root@tlondon ~]#

Comment 2 Bill Nottingham 2011-09-19 20:05:15 UTC

*** This bug has been marked as a duplicate of bug 735618 ***


Note You need to log in before you can comment on or make changes to this bug.