Bug 739563 - The Configuration File Deployment in activation keys deploys from all config channels, even if it it set for just one key
Summary: The Configuration File Deployment in activation keys deploys from all config ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 1.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space16
TreeView+ depends on / blocked
 
Reported: 2011-09-19 14:09 UTC by Jan Pazdziora
Modified: 2012-03-06 09:17 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-09 12:20:16 UTC


Attachments (Terms of Use)

Description Jan Pazdziora 2011-09-19 14:09:02 UTC
Description of problem:

If there are two activation keys, each has one (different) config channel configured to it, and in each of the channel there is a different file, the Configuration File Deployment flag makes all files deployed, even if it is set to just one activation key.

Version-Release number of selected component (if applicable):

# rpm -q spacewalk-backend
spacewalk-backend-1.6.18-1.el5

How reproducible:

Deterministic.

Steps to Reproduce:
1. create config channel ad-test-1 and ad-test-2.
2. to ad-test-1, put file /etc/config-file
3. to ad-test-2, put file /etc/config2-file
4. create activation key 1-test-1, set ad-test-1 config channel to it, leave the Configuration File Deployment checkbox unchecked
5. create activation key 1-test-2, set ad-test-2 config channel to it, check the Configuration File Deployment checkbox
6. on a client registered to this Spacewalk, run
   # rhnreg_ks --activationkey=1-test-1,1-test-2 --force
7. check for /etc/config* files
  
Actual results:

# ls -la /etc/config*
-rw-r--r-- 1 root root 5 Sep 19 16:02 /etc/config2-file
-rw-r--r-- 1 root root 4 Sep 19 16:02 /etc/config-file

Expected results:

# ls -la /etc/config*
-rw-r--r-- 1 root root 5 Sep 19 16:02 /etc/config2-file

because the 1-test-1 (which would bring config-file via the ad-test-1 config channel) has Configuration File Deployment checkbox unchecked.

Additional info:

I came across this issue while investigating bug 600527. It might be related.

Comment 1 Jan Pazdziora 2011-09-20 08:04:25 UTC
Maybe this is actually correct, maybe the flag really means "if this flag is set for at least one activation key, deploy all config files from all config channel", not just from config channels of the key which has the flag set.

Comment 2 Jan Pazdziora 2011-12-09 12:20:16 UTC
Right. It is NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.