Bug 739587 - restorecon should always return 0 on success
Summary: restorecon should always return 0 on success
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: policycoreutils
Version: 6.2
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks: 739953
TreeView+ depends on / blocked
 
Reported: 2011-09-19 15:06 UTC by Rob Crittenden
Modified: 2013-02-25 13:39 UTC (History)
4 users (show)

Fixed In Version: policycoreutils-2.0.83-19.16.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:31:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1637 normal SHIPPED_LIVE policycoreutils bug fix and enhancement update 2011-12-06 00:50:40 UTC

Description Rob Crittenden 2011-09-19 15:06:25 UTC
Description of problem:

The restorecon man page doesn't include possible return values. It apparently returns 0 if it does nothing and 1 if it changes the context. Unclear what other possible values might be.

Version-Release number of selected component (if applicable):

policycoreutils-2.0.83-19.13.el6.i686

Steps to Reproduce:
1. chcon -t ssh_home_t ~/.emacs
2. restorecon ~/.emacs
3. echo $?

Value will be 1.

Comment 2 Daniel Walsh 2011-09-23 15:52:34 UTC
I changed restorecon to return 0 on success like it did in RHEL6.0.

Fixed in policycoreutils-2.0.83-19.16.el6

Comment 5 errata-xmlrpc 2011-12-06 15:31:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1637.html


Note You need to log in before you can comment on or make changes to this bug.