Bug 739595 - Firstboot: Registration screen is not reset after back is clicked from org/env selection
Summary: Firstboot: Registration screen is not reset after back is clicked from org/en...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michael Stead
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel62 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-19 15:35 UTC by Michael Stead
Modified: 2011-12-06 17:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:24:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1695 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2011-12-06 01:23:29 UTC

Description Michael Stead 2011-09-19 15:35:01 UTC
Description of problem:
If the back button is clicked on org/env screen, it is re-displayed the next time the registration FB module is shown.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. start firstboot (ensuring the system is not currently registered)
2. register with a valid username/password.
3. When the org selection screen appears, click "Back"
4. Click "Next" to reload the credentials screen.
  
Actual results:
You are shown the organization selection screen and no longer have to enter valid username/password.

Expected results:
User is prompted to enter credentials again (username/password)

Additional info:

Comment 2 Michael Stead 2011-09-19 19:42:18 UTC
Fixed in branches:

RHEL6.2 - 2da9ada3aa7113f90a9f3bf467353a31682055c8

master - 8fb6a99d36d65a2240a2128435f756816d560df8

Comment 5 J.C. Molet 2011-09-22 19:12:27 UTC
This works as described.  When you click back, it asks you what you want to register to, and if you click forward it takes you to RHSM registeration with the login and password blanked out as if you started over.

Marking VERIFIED.

python-rhsm-0.96.12-1.git.0.4862863.el6.noarch
subscription-manager-firstboot-0.96.11-1.git.1.945da16.el6.x86_64
subscription-manager-0.96.11-1.git.1.945da16.el6.x86_64
subscription-manager-gnome-0.96.11-1.git.1.945da16.el6.x86_64

Comment 6 errata-xmlrpc 2011-12-06 17:24:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html


Note You need to log in before you can comment on or make changes to this bug.