Bug 739595 - Firstboot: Registration screen is not reset after back is clicked from org/env selection
Firstboot: Registration screen is not reset after back is clicked from org/en...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michael Stead
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel62 743047
  Show dependency treegraph
 
Reported: 2011-09-19 11:35 EDT by Michael Stead
Modified: 2011-12-06 12:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:24:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Stead 2011-09-19 11:35:01 EDT
Description of problem:
If the back button is clicked on org/env screen, it is re-displayed the next time the registration FB module is shown.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. start firstboot (ensuring the system is not currently registered)
2. register with a valid username/password.
3. When the org selection screen appears, click "Back"
4. Click "Next" to reload the credentials screen.
  
Actual results:
You are shown the organization selection screen and no longer have to enter valid username/password.

Expected results:
User is prompted to enter credentials again (username/password)

Additional info:
Comment 2 Michael Stead 2011-09-19 15:42:18 EDT
Fixed in branches:

RHEL6.2 - 2da9ada3aa7113f90a9f3bf467353a31682055c8

master - 8fb6a99d36d65a2240a2128435f756816d560df8
Comment 5 J.C. Molet 2011-09-22 15:12:27 EDT
This works as described.  When you click back, it asks you what you want to register to, and if you click forward it takes you to RHSM registeration with the login and password blanked out as if you started over.

Marking VERIFIED.

python-rhsm-0.96.12-1.git.0.4862863.el6.noarch
subscription-manager-firstboot-0.96.11-1.git.1.945da16.el6.x86_64
subscription-manager-0.96.11-1.git.1.945da16.el6.x86_64
subscription-manager-gnome-0.96.11-1.git.1.945da16.el6.x86_64
Comment 6 errata-xmlrpc 2011-12-06 12:24:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.