Bug 739596 - ARM fc14 kernel-devel missing /usr/src/kernels/2.6.40.3-0.fc14.armv7l.tegra/arch/arm/mach-tegra/include/mach
Summary: ARM fc14 kernel-devel missing /usr/src/kernels/2.6.40.3-0.fc14.armv7l.tegra/...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 14
Hardware: arm9
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: D. Marlin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 816761
TreeView+ depends on / blocked
 
Reported: 2011-09-19 15:36 UTC by William Cohen
Modified: 2012-04-26 21:57 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 816761 (view as bug list)
Environment:
Last Closed: 2012-02-20 15:32:00 UTC


Attachments (Terms of Use)
Add the arch/arm/mach-<ArmVariant>/include direcetory to the -devel package (707 bytes, patch)
2011-12-08 19:50 UTC, D. Marlin
no flags Details | Diff

Description William Cohen 2011-09-19 15:36:08 UTC
Description of problem:

Attempting to use systemtap on fc14. Systemtap builds kernel modules and installs them to instrument the machine. For this to work need to have kernel-devel (or kernel-tegra-devel) able to build modules on the machine. The machine attempting this on is a trimslice pro.


Version-Release number of selected component (if applicable):

kernel-tegra-devel-2.6.40.3-0.fc14.armv7l
kernel-tegra-2.6.40.3-0.fc14.armv7l
kernel-headers-2.6.40.3-0.fc14.armv5tel
kernel-tegra-debuginfo-2.6.40.3-0.fc14.armv7l
kernel-debuginfo-common-armv7l-2.6.40.3-0.fc14.armv7l
systemtap-1.6-1.fc14.armv5tel

How reproducible:

Every time.

Steps to Reproduce:
1. Install the rpms above from koji (note needed to rebuild systemtap rpm because of corruption in the koji files)
2. As root run the example from http://sourceware.org/systemtap/SystemTap_Beginners_Guide/using-systemtap.html#testing:
stap -v -e 'probe vfs.read {printf("read performed\n"); exit()}'
3.
  
Actual results:

Unable to run the example get something of like the following:


# stap -v -e 'probe vfs.read {printf("read performed\n"); exit()}'
Pass 1: parsed user script and 75 library script(s) using 25584virt/13556res/2372shr kb, in 810usr/20sys/824real ms.
Pass 2: analyzed script: 1 probe(s), 22 function(s), 3 embed(s), 1 global(s) using 150328virt/60464res/5208shr kb, in 5600usr/1420sys/7033real ms.
Pass 3: translated to C into "/tmp/staphzZAYs/stap_c503d6077a64f71e36e8bfde58f7d09a_10763.c" using 145720virt/59608res/6400shr kb, in 2050usr/420sys/2474real ms.
In file included from /usr/src/kernels/2.6.40.3-0.fc14.armv7l.tegra/arch/arm/include/asm/bitops.h:27:0,
                 from include/linux/bitops.h:22,
                 from include/linux/kernel.h:17,
                 from include/linux/cache.h:4,
                 from include/linux/time.h:7,
                 from include/linux/stat.h:60,
                 from include/linux/module.h:10,
                 from /usr/share/systemtap/runtime/runtime.h:14,
                 from /tmp/staphzZAYs/stap_c503d6077a64f71e36e8bfde58f7d09a_10763.c:59:
/usr/src/kernels/2.6.40.3-0.fc14.armv7l.tegra/arch/arm/include/asm/system.h:159:27: fatal error: mach/barriers.h: No such file or directory
compilation terminated.


Expected results:

The instrumentation compiled into a kernel module which include the following line in the output:

read performed



Additional info:

Looking at local rpmbuild of kernel rpm see:

$ls rpmbuild/BUILD/kernel-2.6.39.fc14/linux-2.6.39.armv5tel/arch/arm/mach-tegra/include/mach/
barriers.h     entry-macro.S  irqs.h       powergate.h           timex.h
clkdev.h       gpio.h         kbc.h        sdhci.h               uncompress.h
clk.h          hardware.h     memory.h     suspend.h             usb_phy.h
debug-macro.S  io.h           pinmux.h     system.h              vmalloc.h
dma.h          iomap.h        pinmux-t2.h  tegra_wm8903_pdata.h

Don't see the include/mach in the kernel-tegra-devel:

$ls /usr/src/kernels/2.6.40.3-0.fc14.armv7l.tegra/arch/arm/mach-tegra/
Kconfig  Makefile  Makefile.boot


Manually copied the missing include directory over to /usr/src/kernels/2.6.40.3-0.fc14.armv7l.tegra/arch/arm/mach-tegra/ and things ran.

Comment 1 Mark Wielaard 2011-11-23 19:38:24 UTC
Same for 2.6.40.4-6.fc15.armv7hl.tegra

Comment 2 D. Marlin 2011-12-08 19:50:47 UTC
Created attachment 542714 [details]
Add the arch/arm/mach-<ArmVariant>/include direcetory to the -devel package

I have been building a slightly different version of the kernel, but I believe this patch to the kernel.spec file will copy the missing include directory to the appropriate location in the kernel-*-devel packages.

Comment 3 William Cohen 2012-02-20 15:32:00 UTC
See that this is fixed in kernel-tegra-devel-2.6.42.3-2.fc15.armv7hl


Note You need to log in before you can comment on or make changes to this bug.