Bug 739628 - seinfo -r displays 12 roles and 1 type
Summary: seinfo -r displays 12 roles and 1 type
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy
Version: 6.2
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 16:39 UTC by Milos Malik
Modified: 2016-08-03 07:56 UTC (History)
1 user (show)

Fixed In Version: selinux-policy-3.7.19-112.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 10:19:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1511 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2011-12-06 00:39:17 UTC

Description Milos Malik 2011-09-19 16:39:17 UTC
Description of problem:
I'm not sure if the bug belongs to selinux-policy or setools.

Version-Release number of selected component (if applicable):
policycoreutils-2.0.83-19.15.el6.i686
policycoreutils-gui-2.0.83-19.15.el6.i686
policycoreutils-python-2.0.83-19.15.el6.i686
selinux-policy-3.7.19-110.el6.noarch
selinux-policy-targeted-3.7.19-110.el6.noarch

How reproducible:
always

Steps to Reproduce:
# seinfo -r

Roles: 13
   guest_r
   lsassd_t
   staff_r
   user_r
   git_shell_r
   logadm_r
   object_r
   sysadm_r
   system_r
   webadm_r
   xguest_r
   nx_server_r
   unconfined_r
# seinfo -r | grep _t
   lsassd_t
#
  
Actual results:
* 12 roles + 1 type are displayed

Expected results:
* 12 roles are displayed

Comment 1 Miroslav Grepl 2011-09-19 16:59:02 UTC
This is caused by

seutil_run_semanage(lsassd_t, lsassd_t)

should be

seutil_run_semanage(lsassd_t, system_r)


Good catch.

Comment 2 Miroslav Grepl 2011-09-20 15:31:37 UTC
Fixed in selinux-policy-3.7.19-112.el6

Comment 5 errata-xmlrpc 2011-12-06 10:19:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1511.html


Note You need to log in before you can comment on or make changes to this bug.