Bug 739636 - Fedora specific armv7hl (hardfp) configuration required for F15 HardFP Bootstrap
Fedora specific armv7hl (hardfp) configuration required for F15 HardFP Bootstrap
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2011-09-19 13:01 EDT by Jon Masters
Modified: 2011-10-21 11:28 EDT (History)
6 users (show)

See Also:
Fixed In Version: redhat-rpm-config-9.1.0-13.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-18 18:17:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jon Masters 2011-09-19 13:01:13 EDT
Description of problem:

We need to override some RPM defaults for Fedora 15 on ARM systems. This includes defaulting to harfp (armv7hl) on armv7hl/hnl, and setting the optflags to target armv7-a, and disable Thumb. We don't use Thumb on Fedora at this moment in time because it causes some builds to fail, and for other reasons.

Specific changes:

optflags: armv7l %{__global_cflags} -march=armv7-a -mfloat-abi=soft
optflags: armv7hl %{__global_cflags} -march=armv7-a -mfpu=vfpv3-d16  -mfloat-abi=hard
optflags: armv7hnl %{__global_cflags} -march=armv7-a -mfpu=neon  -mfloat-abi=hard

buildarchtranslate: armv7l: armv7hl
buildarchtranslate: armv7hl: armv7hl
buildarchtranslate: armv7hnl: armv7hl
Comment 1 Fedora Update System 2011-09-19 13:32:16 EDT
redhat-rpm-config-9.1.0-13.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/redhat-rpm-config-9.1.0-13.fc15
Comment 2 Fedora Update System 2011-09-19 18:57:35 EDT
Package redhat-rpm-config-9.1.0-13.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing redhat-rpm-config-9.1.0-13.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/redhat-rpm-config-9.1.0-13.fc15
then log in and leave karma (feedback).
Comment 3 Jens Petersen 2011-10-06 04:27:03 EDT
Is this change needed also for f16 and f17?
Comment 4 Jens Petersen 2011-10-06 04:33:58 EDT
(In reply to comment #3)
> Is this change needed also for f16 and f17?

Nevermind, Henrik pointed out that the change is actually already merged.
Not so obvious though looking at the spec file or pkg git...
Comment 5 Fedora Update System 2011-10-18 18:17:50 EDT
redhat-rpm-config-9.1.0-13.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.