Bug 73964 - Does not work when installed with an umask of 077 and messes filesystem
Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: php-dbg-base (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
http://www.tu-chemnitz.de/~ensc/dirch...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 11:43 EDT by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 05:56:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 11:43:56 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/include/dbgbase /usr/include/dbgbase/dbg_net.h
| file /usr/include/dbgbase is not owned by any package
| php-dbg-base-2.10-3


Version-Release number of selected component (if applicable):

php-dbg-base-2.10-3


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that php-dbg-base is uninstalled completely
   (rm -rf /usr/include/dbgbase)
3. rpm -U php-dbg-base-2.10-3.i386.rpm
4. ls -l /usr/include/dbgbase
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e php-dbg-base-2.10-3

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 17:03 /usr/include/dbgbase
* files can not be found/read at 5 and
* /usr/include/dbgbase still exists after 6.
Comment 1 Joe Orton 2003-01-13 05:56:17 EST
php-dbg-* were dropped in the Phoebe beta; this bug is not worth an erratum, so
it's unlikely this will get fixed.

Note You need to log in before you can comment on or make changes to this bug.