Bug 739657 - Deployment State remains "pending"
Summary: Deployment State remains "pending"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 0.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
Assignee: Angus Thomas
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 18:19 UTC by Joe Vlcek
Modified: 2012-05-15 21:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 21:55:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0583 normal SHIPPED_LIVE new packages: aeolus-conductor 2012-05-15 22:31:59 UTC

Description Joe Vlcek 2011-09-19 18:19:54 UTC
Description of problem:

After launching a Deployable with a single EC2 instance the "State"
stays listed as "pending". This was done using 

This was done using older Aeolus bits, prior to hitting Bug
739579 - Deployable fails to launch on EC2,
(https://bugzilla.redhat.com/show_bug.cgi?id=739579 )

e.g.:

GoDaddy Deployment
     Instances 1
    Properties

    GoDaddy/Joe Assem
        IP Address:
        State: pending
    Download key

Using the EC2 dashboard I was able to log in and see the running
instance listed.

The key downloaded from Conductor allow access to the instance.


Version-Release number of selected component (if applicable):


How reproducible:

Configure Conductor for EC2, attempt to launch a deployable with
at least one "Assembly" with an EC2 "Image ID"


Steps to Reproduce:
1. install previous version... (I realize this is nebulous but after
Bug 739579 my hope is that filing this bug will help confirm this
is no longer an issue.)

2. Run aeolus-configure
3. Attempt to launch deployable
  
Actual results:


Expected results:

Expect the state to change to running, a valid IP Address be listed
and a "Stop" instance or deployable switch to become available.


Additional info:

Comment 1 wes hayutin 2011-09-22 14:02:56 UTC
on_qa because condor has been removed.. testing w/ new feature

Comment 2 wes hayutin 2011-09-23 19:57:32 UTC
Instances  3  Properties
Graphic ViewFilter View
Instances
testThree/frontend
IP Address: ec2-184-73-128-223.compute-1.amazonaws.com
State: running
Download key
testThree/middle
IP Address: ec2-50-16-6-150.compute-1.amazonaws.com
State: running
Download key
testThree/back
IP Address: ec2-107-20-27-153.compute-1.amazonaws.com
State: running
Download key


[root@unused ~]# rpm -qa | grep aeolus
aeolus-conductor-doc-0.4.0-0.20110922165939git5b371be.fc15.noarch
aeolus-conductor-0.4.0-0.20110922165939git5b371be.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110922165939git5b371be.fc15.noarch
aeolus-all-0.4.0-0.20110922165939git5b371be.fc15.noarch
aeolus-conductor-devel-0.4.0-0.20110922165939git5b371be.fc15.noarch
aeolus-configure-2.0.2-4.20110921102958gitcaa9608.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110922120732gita0b9a44.fc15.noarch
[root@unused ~]#

Comment 5 errata-xmlrpc 2012-05-15 21:55:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html


Note You need to log in before you can comment on or make changes to this bug.