Bug 73966 - Does not work when installed with an umask of 077 and messes filesystem
Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: pxe (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Brock Organ
http://www.tu-chemnitz.de/~ensc/dirch...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 11:44 EDT by Enrico Scholz
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-11 11:04:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 11:44:35 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /tftpboot/X86PC/UNDI /tftpboot/X86PC/UNDI/BStrap
| file /tftpboot/X86PC/UNDI is not owned by any package
| pxe-0.1-33


Version-Release number of selected component (if applicable):

pxe-0.1-33


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that pxe is uninstalled completely
   (rm -rf /tftpboot/X86PC/UNDI)
3. rpm -U pxe-0.1-33.i386.rpm
4. ls -l /tftpboot/X86PC/UNDI
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e pxe-0.1-33

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 17:44 /tftpboot/X86PC/UNDI
* files can not be found/read at 5 and
* /tftpboot/X86PC/UNDI still exists after 6.
Comment 1 Daniel Walsh 2003-04-11 11:04:10 EDT
We are dropping support for pxe in the RHEL release and will drop it from future 
Red Hat Linux release.  
We are recommending that you use dhcp/pxelinux for X86 platforms.  

Note You need to log in before you can comment on or make changes to this bug.